Openbox Menu: gaps between submenus


#1

Hi there, I don’t know what I’ve done, but suddenly I had this huge gaps between the OB submenus:
obmenugap
I tried to disable shadow to get rid of the gaps but it didn’t worked, any ideas?


#2

Were you tweaking the theme? There are menu x,y offsets in there. Nothing like what you have going on there, though.

Try changing the openbox theme.


#3

Thanks, I changed the the via OB Settings GUI - switcing to another one helps. Where can I change the menu x/y offsets?


#4

You would need to edit the themerc file for the openbox theme.

None of the offsets are that large by default though, so you have something else going on.

Do all the fonts look good? Not oversized or anything like that?

Go ahead and post the specs for your graphics and monitor; might be some sort of gaphics/resolution issue.


#5

Thanks alot so far!

Fonts are fine and everything except the OBMenu looking good!
I am on a ThinkPad x240 with 12,5" (?) and 1080p.
Not tried all of them preinstalled themes, but it seems only to effect the ones named ArchLabs-*** and is worse with the dark ones. The others I’ve tried only have offsets between 0 and maybe 5 pixels. In the themerc there is no offset set / no appearence of ‘offset’

I may search for other themes later, but I would really like to understand whats oing on.


#6

Sorry, it’s referred to as “overlap” in the themerc

menu.overlap.x: 0
menu.overlap.y: 0

are the options, can be positive or negative for left, right, up, down.

Several users have had to use xrandr to fix some resolution issues - but nothing like what you have going on. You can search the forum for “xrandr” maybe get a clue as to what’s going on.


#7

Thanks, again!
menu.overlap.x
was set to -20, I don’t know why but all fine!


#8

I just looked at that -

menu.overlap.x:  -20
menu.overlap.y:	   0

Looks fine on my monitor (1440x900) doesn’t work too well on your laptop apparently.

Only openbox menu is affected, right? So webpages, text editor all viewable with the correct resolution?


#9

Ah, thats weird. Yes, only openbox menu. I am not sure but I think the gaps appeared after I changed theme from AL-dARK to AL-Dark and rebooted for another reason. I am on a fresh install of ArchLabs I never used before, but now I just love it!


#10

with
menu.overlap.x: -5
this is how it looks like:
fixedgaps
sidefact: while fixing I realized the above row where the only one in themerc, where the value wasn’t in place. Instead itt looked like this:

menu.overlap.x:                                          -20
menu.overlap.y:	   0

This not making any difference, just wondered because I had not touched the file myself.


#11

Shouldn’t have mattered; if openbox is suddenly reading white space in the themerc that would be a new bug.


#12

hello entr0py, I had a very similar issue with the compositing manager and some themes in openbox …:eyes: