Openbox keybinding not working

i am trying to run rofi not rofr.sh with super key. However, i am not able to do so. when i press super key openbox throws an error saying cant find rofr.sh though in my rc.xml the key super(alt+f1) is bound to run rofi not rofr.sh. which config is overriding the rc.xml?

You need to define keybindings… redefine your superkey (I assume Win key).

Edit: I use sxhkd for that service on all my window managers including OB. Call sxhkd from .xprofile

### shared common keybindings (applications)
sxhkd -c ~/.config/sxhkd/base.conf &

the ksuperkey is defined in your ~/.xprofile.

Post the actual snippet for the key binding in your rc.xml.

How old is this install? rofi_run.sh is the current file name. Should be in your ~/bin or ~/.local/bin

1 Like

win key redefined as alt+f1 using ksuperkey. and in my openbox rc.xml alt+f1 is bound to run rofi.

Just running rofi is not a sufficient command, you would at least need rofi -show MODE where MODE is one of the available modes (run, drun, window, etc.).

1 Like

i am trying to view drun. with ‘rofi -show drun’ command but openbox is trying to find rofi_run (which was a renamed rofr.sh).
image
If I run rofi -show run then it shows run and then i can actually switch to drun mode by pressing shift+arrow key.
If I replace the rofr.sh in the bin folder, then rofi shows the drun window.

Post your rc.xml

rc.xml

Hmm, very strange. You’ve restarted the wm at this point I assume?

I reconfigured, restarted openbox. Shutdown my laptop to go to sleep at night. Same thing keeps happening.
It’s not like that the system is unusable or anything. It’s just a strange issue that I want to be resolved. But I’m at my wits end here :confused:.

Yea understandable.

I’m really not sure either, is it only an issue with Alt-F1? Like can you bind the same command to a seperate key to see if that works?

If I try to run rofi -show drun with other keybinding that actually work. Now I am going to bind that key comnination (alt+f2) to win key and see if that work.
one interesting thing is, i tried to run rofi --show run using the alt+f1 combination. However, instead of showing the run window, it is showing the drun mode of rofr.sh :confused: :smile:

1 Like

I have found the underlying reason behind this issue. In my xfce4 keyboard setting, alt+f1 was bound to rofr.sh. xfce4 setting was auto-started in openbox. But I’m confused about why xfce keybinding would override openbox keybinding.

Good old xfce keyboard settings. Glad you found the issue.

1 Like

Aha, damn that’s a good find.

Perhaps start the xfce settings before openbox, not in the autostart. I’ll need to look into a better solution for this in future installs.

2 Likes

I lost some hair in the process though :smile:

I’ve gone through a similar experience when I first started using two monitors

Thanks a lot for being here :slightly_smiling_face:

1 Like

it’s very confusing :smiley:

1 Like