On activating 2nd monitor all black but still have mouse cursor on both montiors

So, I installed AL OB on my work office computer (not my normal lappy installation at home)
I installed a couple of apps (xfce4-terminal, yay, Joplin, FF and a couple more)
All great
But it was only on my main monitor and so I opened “xfce4-display-settings”, “Display” and activated the second monitor

Unfortunately this made both monitors go black but the mouse cursor arrow was still visible and moved from one monitor to the other as expected.

I tried ctrl+alt+F2 to get into tty2 but no luck
Disconnecting the second monitor did nothing
I tried [S]+x then logout to try to get out, but no luck so I shut off the power button
On reboot the same thing, just the main monitor was now grey

I am at a bit of a loss

Anyone have any ideas for me?

I installed with vanilla kernel

Thanks

Maybe try ARandR instead of xfce4-display-settings.

3 Likes

What s the hardware @leigh . It might help a bit.

Edit, We almost post on the same time.

1 Like

Thanks. First step is to try to get some display back.

I found this in one of my Joplin notes :
Motherboard
Gigabyte Technology Co. Ltd. H81M-S1
Graphics
Intel HD Graphics 4400 (Gigabyte)
64MB NVIDIA GeForce 6200 TurboCache (MSI) 60 °C F

1 Like

I tried ctrl+alt+F3 to get into tty but no luck

1 Like

Have you checked your bios settings for ctrl+alt is enable?

2 Likes

Thanks all,

@elloquin - do you mean try ctrl+alt+F3?
I tried F1 to F9 in desperation :slight_smile:

@sammiev
Nope, will do

I cant wait to get back into work to try today
AL does strange things to me :joy:

At the end of the day if I cant get out of the black screen I will just reinstall from scratch as it didnt take more than a few minutes, but it would be nice to work out for the next time

1 Like

Just checked my bios settings and I had to enable ‘Fool Proof Fn Control’.

1 Like

@sammiev
I dont have anything like that in my bios settings.

I disconnected the 2nd monitor (which is the intel one) and all is fine on the NVidia one
Now the ctrl+alt+F# works :grinning:

1 Like

Perfect !

But on reconnecting the second monitor the system freaks out.
Black screen on monitor 2 (vga-1 on intel onboard) with mirrored mouse arrow) and monitor 1 (vga-2 on Nvidia card) showing stuff but hugely unresponsive.

Using arandr or xfce4 settings same

Mmmmmm…

Oh, you’re using both GPUs. I’ve never tried on a lappy, but the desktops I’ve tried didn’t work.

Thanks @eight_bit_al
Its a desktop, not my lappy.
If i dont use both gpus how can i use dual monitor?
There is a dvi port on the nvidia as well as the serial one (the blue ones)
It was set up like this in, gasp, Win10 :grinning:

Linux is weak on dual GPUs that aren’t the same make/model, gaming rigs.

https://wiki.archlinux.org/title/hybrid_graphics
This technology is well supported on Windows but it is still rough around the edges with Linux distributions.

Oh.
Funny tho, as my lappy at home has an intel snd an Nvidia gpus in it and its fine. Maybe this desktop and gpus are just too old

Looks like you may have found one of the rough edges.

1 Like

Funnily enough, with just the nvidia gpu monitor FF is a bit laggy but i have near 1 Gbps on speedtest.
Will try swapping main monitor ro intel

No luck.
Tried installing nvidia
Now nothing works
Wont even startx
Uninstalled nvidia from cli and stiil same
Bugger :joy:
Something about 304 legacy drivers for this gpu
Now exceptions and fatal errors
That dont sound very healthy
Reinstall coming up

Run both monitors off the NVIDIA card, even if you have to use a VGA adapter
I’d need the specs of the monitors to be more helpful.

1 Like

I am now reinstalled, with just the LG monitor on the Nvidia GPU (integrated Intel output doesn’t work with Nvidia card in)

I did try taking out the NVIDIA card and using the integral intel GPU (which worked then ) but no real difference - I even thought it didnt look as clear/focused but that could be car running better after filling up syndrome

Main monitor
LG 24M38H

2nd Monitor
HPw1907

I have to say, everything feels a bit sluggish, especially in browser, despite high Speedtest results
Also, scrolling seems to hesitate / has a delay
Perhaps my work computer is worse than I thought?
you would think we would have up to date ones in a Uni Eng dept …

EDIT: definitely laggy scrolling etc. The EeePC is snappier, but this desktop boots in an instant which the EeePC definitely doesnt :). I wonder why?

Edit 2: Booting into Windows on the HDD is 100s of times slower, but once in scrolling in FF browser and loading pages much, much faster and no not so much laggyness

leigh@archlabs ~ % sudo lshw -short
[sudo] password for leigh: 
H/W path       Device  Class          Description
=================================================
                       system         H81M-S1 (To be filled by O.E.M.)
/0                     bus            H81M-S1
/0/0                   memory         64KiB BIOS
/0/4                   memory         128KiB L1 cache
/0/5                   memory         512KiB L2 cache
/0/6                   memory         3MiB L3 cache
/0/7                   memory         8GiB System Memory
/0/7/0                 memory         8GiB DIMM DDR3 Synchronous 1600 MHz (0.6 ns)
/0/7/1                 memory         DIMM [empty]
/0/7/2                 memory         DIMM [empty]
/0/7/3                 memory         DIMM [empty]
/0/40                  processor      Intel(R) Core(TM) i3-4170 CPU @ 3.70GHz
/0/100                 bridge         4th Gen Core Processor DRAM Controller
/0/100/1               bridge         Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller
/0/100/1/0             display        NV44 [GeForce 6200 TurboCache]
/0/100/2               display        4th Generation Core Processor Family Integrated Graphics Controller
/0/100/3               multimedia     Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
/0/100/14              bus            8 Series/C220 Series Chipset Family USB xHCI
/0/100/14/0    usb3    bus            xHCI Host Controller
/0/100/14/0/4          input          USB Keyboard
/0/100/14/0/6          input          USB Receiver
/0/100/14/1    usb4    bus            xHCI Host Controller
/0/100/16              communication  8 Series/C220 Series Chipset Family MEI Controller #1
/0/100/1a              bus            8 Series/C220 Series Chipset Family USB EHCI #2
/0/100/1a/1    usb1    bus            EHCI Host Controller
/0/100/1a/1/1          bus            Integrated Rate Matching Hub
/0/100/1b              multimedia     8 Series/C220 Series Chipset High Definition Audio Controller
/0/100/1c              bridge         8 Series/C220 Series Chipset Family PCI Express Root Port #1
/0/100/1c.2            bridge         8 Series/C220 Series Chipset Family PCI Express Root Port #3
/0/100/1c.2/0  enp3s0  network        RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
/0/100/1d              bus            8 Series/C220 Series Chipset Family USB EHCI #1
/0/100/1d/1    usb2    bus            EHCI Host Controller
/0/100/1d/1/1          bus            Integrated Rate Matching Hub
/0/100/1f              bridge         H81 Express LPC Controller
/0/100/1f.2            storage        8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode]
/0/100/1f.3            bus            8 Series/C220 Series Chipset Family SMBus Controller
/0/1                   system         System Board
/0/2                   system         Motherboard registers
/0/3                   system         AT Real-Time Clock
/0/8                   generic        PnP device INT3f0d
/0/9                   system         Motherboard registers
/0/a                   system         Motherboard registers
/0/b                   system         Motherboard registers
/1                     power          To Be Filled By O.E.M.