Nvidia installation causes my system stuck after rebooting

You can see that picom is already listed so edit the file at ~/.xprofile and change the picom line so that it looks like this:

picom --backend glx &

@natemaia — it’s probably best to drop the -b option for picom because the ampersand already fork()s it and having two calls for that action may cause a race condition. Also xfce4-power-manager & nitrogen don’t need the ampersand on their lines and that may also cause races.

Changing picom and removing the ampersand did not fix the problem, what I saw was that removing the ampersand from xfce4-power-manager my system boots but only my wall paper appears, there is not status bar and the commands are not working at all, in other words the system does no work.

After I only left picom & and the system boots but my screen tearing persist. Finally what i did was to remove the ampersand from picom and the system boot but stucked in a black screen.

Finally I went back to picom -b & in order to have my system back

Sorry, the ampersand comments were not directed at you. I was wrong about xfce4-power-manager anyway, I must have mis-remembered that detail.

The only line you should have changed was the picom line and you should have changed it so that it looked exactly as I posted:

picom --backend glx &

So with an ampersand and --backend glx but without -b. Did you try that?

There is also the vsync option:

picom --backend glx --vsync opengl-mswc &

You don’t have to run any compositor in your system if you’re using X.

1 Like

Yea I had noticed this when running picom the other day, double forking not so great. I doubt a race will ever happen but its still terrible practice. I’ll update the AL files tonight, the heads up is much appreciated :slight_smile:

1 Like

Sorry for the late reply I’ve being busy.

Well, I tried both, and the error persists

Thank you in advance


@baezacaljo Did you try without using a compositor?

Sorry for then late reply ive been quite busy with my job.
First of all sorry for ignorance.

Look i don’t know how to remove a compositor.

What i did was to remove the picom line from the file and the problem persist.

Thanks in advance