Nvidia installation causes my system stuck after rebooting

Hello dear all.

looking for help again.

well, after the final installation of my system i noticed that NVIDIA was not loaded, let me tell you first that i have an nvida card “NVIDIA GeForce 7150M / nForce 630” therefore i decided to install the nvidia drives using the next steps.

to check my nivida card i used

lspci | grep -E “VGA|3D”

the output was

00:12.0 VGA compatible controller: NVIDIA Corporation C67 [GeForce 7150M / nForce 630M] (rev a2)

also i applied

sudo pacman -Syyu

then i installed the nvidia drivers using the following command

sudo pacman -S nvidia nvidia-utils nvidia-settings xorg-server-devel opencl-nvidia

Once installed i checked that nouveau module is in blacklist with the following

cat /usr/lib/modprobe.d/nvidia.conf

the output was

blacklist nouveau

finally i rebooted. Here the problem appears.

when i wait for rebooting process my computer did not start only was stuck and did not boot.

so what i did to get my system back was to plugged my USB and and enter to installation mode after that i mount the parts and use

arch-chroot /mnt

from there i unistalled nvidia using

sudo pacman -Rs nvidia

So doing this was only way t get my system back but no NVIDIA was installed at all.

therefore i am looking for help.

What can i do? how to solve my problem?

Also i attach a picture of my system

thanks in advance

You need nvidia-340xx driver, not nvidia since you have a legacy card in your system. Always try to use ArchWiki as the first reference for help.

Now you need yay to install nvidia-340xx-dkms from AUR.

    1. sudo pacman -S git base-devel
    2. git clone https://aur.archlinux.org/yay-git.git
    3. cd yay-git
    4. makepkg -si
    5. yay -Syyu && yay -Fyy
    6. yay -S nvidia-340xx-dkms
    7. sudo reboot
3 Likes

^ This. I had the same problem once my card became legacy. Needed to switch driver package

The user can also use baph to install packages from the AUR; baph is ArchLabs’ home grown software and installed by default.

2 Likes

thanks for your answer chroot.

i wet through the steps and my computer did stuck anymore however when i run the command

lspci -k | grep -A 2 -E "(VGA|3D)"

i get the following output

00:12.0 VGA compatible controller: NVIDIA Corporation C67 [GeForce 7150M / nForce 630M] (rev a2)
Subsystem: Hewlett-Packard Company Device 30cf
Kernel driver in use: nouveau

as far as i can see nouveau still present. instead of nouveau must be nvidia, right?.

or, is that ok?.

thanks

thanks for your advice PackRat. however, i am quite new using linux. Therefore, can you explain a little bit more what should i do.

thanks

I think that card is only supported by the 304.xx driver[0] but unfortunately that won’t build with the current kernel versions. Looks like you’re stuck with Nouveau.

Next time buy AMD instead, NVIDIA hate open source and happily drop support for old cards to make you buy new ones. The bastards.

EDIT: the 304.xx driver still works with Debian stretch but the rest of the software in oldstable is equally dated.

1 Like

There are several applications that let you install packages from the AUR. I was just pointing out that ArchLabs has baph installed by default. It works and is maintained by the ArchLabs developers.

If you followed @chroot instructions you should be good.

2 Likes

Thank you very much @Head_on_a_Stick .

I got it, I can see the point of it. Well, I’ll stick to nouveau.

My reason to get the Nvidia was because I saw some “screen tearing” while moving the windows also the same situation happens when I watch some videos in YouTube.

Therefore, could I solve the tearing with nouveau?. Or do I have to open another topic?.

Thanks again

Thank @PackRat now I got it.

Well, I performed the previous steps and I am in nouveau driver, so I was reading another comments and it seems I stuck with nouveau.

Try picom, start it like this:

picom --backend glx &

You’re right. It’s 304. Very old driver.

thanks for the help.

i dont think the tearing is solved because i got the folling output

[ 02/16/2021 13:11:25.782 session_init FATAL ERROR ] Another composite manager is already running

[1]  + 591 exit 1     picom --backend glx

Which desktop are you using? Xfce has an option to disable their native compositor so that you can replace it with picom.

Also i performed a test in youtube and the tearing is quite big

I have openbox, i tried to keep everything simple and light my computer is quite old and slow already

So check ~/.config/openbox/autostart & ~/.xprofile to see which compositor is being started.

If nothing relevant is listed there then try

/usr/lib/x86_64-linux-gnu/openbox-xdg-autostart --list

^ That should show all programs that are initiated via the XDG autostart paradigm.

i dont know is my system is really messed up. look the output of the first command is:

(using nano otherwise as executable says “./autostart: command not found”)
for the first command

~/.config/openbox/autostart

the output using nano is

# required for xfce settings to work
xfsettingsd &

# start the panel
tint2 &

# load wallpaper
nitrogen --restore &

after i tried

~/.xprofile

and the output is

not a directory: /home/alberto/.xprofile

finally in the last command i faced this

instead of having x86_64-linux-gnu i got openbox.

having my final path as

~/.config/openbox

then i ran

openbox-xdg-autostart --list

and i got

./openbox-xdg-autostart --list

ERROR: openbox-xdg-autostart requires PyXDG to be installed

~/.xprofile is a file and should be in your home directory. If it’s not there, something went wrong during installation. There is a line to start picom in that file.

1 Like

Both ~/.xprofile and ~/.config/openbox/autostart are text files rather than commands. The XDG autostart listing command should be run exactly as I posted it, which is why I posted it like that.

But anyway there does appear to be a compositor running so can we please see the output of these commands:

cat ~/.xprofile
pstree

Look, as @PackRat mentioned before probably something went wrong during my installation. Therefore i reinstalled all over again.

This time the files appeared specially the .xprofile. With that being said, i applied the command

picom --backend glx &

the output was

[ 02/17/2021 14:29:35.499 session_init FATAL ERROR ] Another composite manager is already running

[1]+  Exit 1                  picom --backend glx

after that i checked the files ~/.config/openbox/autostart and ~/.xprofile.

the output of ~/.config/openbox/autostart

# required for xfce settings to work
xfsettingsd &

# start the panel
tint2 &

# load wallpaper
nitrogen --restore &

the output of ~/.xprofile

#!/bin/sh

# sourced at boot by ~/.xinitrc and most display managers

export XDG_CONFIG_HOME="$HOME/.config"
export PATH="$HOME/.local/bin:$PATH"

picom -b &
nm-applet &
volumeicon &
nitrogen --restore &
xfce4-power-manager &
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &
gnome-keyring-daemon --start --components=pkcs11 &
ksuperkey -e 'Super_L=Alt_L|F1' &
ksuperkey -e 'Super_R=Alt_L|F1' &
xset dpms 600 900 1200
xset r rate 350 60

and for the last command /usr/lib/x86_64-linux-gnu/openbox-xdg-autostart --list

i got the next output

/usr/lib/x86_64-linux-gnu/openbox-xdg-autostart --list
bash: /usr/lib/x86_64-linux-gnu/openbox-xdg-autostart: No such file or directory

for that one, i still have the same as i mentioned before /usr/lib/openbox/openbox-xdg-autostart and the out put is the same as i mentioned before.

finally, the cat ~/.xprofile i did not perferomed because as i mentioned before we have already a ~/.xprofile file

However, for the output of the pstree

systemd─┬─NetworkManager───2*[{NetworkManager}]
        ├─dbus-daemon
        ├─firefox─┬─Privileged Cont───17*[{Privileged Cont}]
        │         ├─Web Content───15*[{Web Content}]
        │         ├─Web Content───18*[{Web Content}]
        │         ├─Web Content───14*[{Web Content}]
        │         ├─WebExtensions───16*[{WebExtensions}]
        │         └─59*[{firefox}]
        ├─gnome-keyring-d───3*[{gnome-keyring-d}]
        ├─2*[ksuperkey───{ksuperkey}]
        ├─login───bash───startx───xinit─┬─Xorg───4*[{Xorg}]
        │                               └─openbox─┬─nm-applet───7*[{nm-applet}]
        │                                         ├─polkit-gnome-au───6*[{polkit-gnome-au}]
        │                                         ├─volumeicon───7*[{volumeicon}]
        │                                         └─xfce4-power-man───6*[{xfce4-power-man}]
        ├─picom───4*[{picom}]
        ├─polkitd───5*[{polkitd}]
        ├─rtkit-daemon───2*[{rtkit-daemon}]
        ├─systemd─┬─(sd-pam)
        │         ├─at-spi-bus-laun─┬─dbus-daemon
        │         │                 └─3*[{at-spi-bus-laun}]
        │         ├─at-spi2-registr───2*[{at-spi2-registr}]
        │         ├─dbus-daemon
        │         ├─dunst───2*[{dunst}]
        │         ├─gvfsd───2*[{gvfsd}]
        │         ├─gvfsd-fuse───5*[{gvfsd-fuse}]
        │         ├─pulseaudio─┬─gsettings-helpe───3*[{gsettings-helpe}]
        │         │            └─{pulseaudio}
        │         └─xfconfd───2*[{xfconfd}]
        ├─systemd-journal
        ├─systemd-logind
        ├─systemd-udevd
        ├─terminator─┬─bash───pstree
        │            └─3*[{terminator}]
        ├─tint2
        ├─upowerd───2*[{upowerd}]
        ├─wpa_supplicant
        └─xfsettingsd───2*[{xfsettingsd}]

thank you very much @Head_on_a_Stick