No screens found

Tried to install AL today and thought it went well but when i installed nvidia drivers for my geforce 1060 all i got was an black screen with a blinking -. When i changed to another console and tried to startx i got the error No screens found, what am i doing wrong? The drivers works in ubuntu.

^ This usually indicates that kernel mode setting (KMS) needs to be disabled.

To do this, press “e” with the ArchLabs boot menu entry highlighted then add nomodeset nouveau.modeset=0 to the end of the line that ends with “linux” (also add i915.modeset=0 if you have a integrated Intel card)n then press <Ctrl>+x (at the same time) to boot the modified entry.

If this works, add the parameters to GRUB_CMDLINE_LINUX in /etc/default/grub and run sudo grub-mkconfig -o /boot/grub/grub.cfg to update the boot menu.

Is this a laptop or desktop?

If it’s a desktop then make sure you have the correct driver packages installed

sudo pacman -S lib32-libvdpau lib32-nvidia-utils libvdpau libxnvctrl nvidia nvidia-settings nvidia-utils

If all is well now run sudo nvidia-xconfig this will create a default config /etc/X11/xorg.conf after restarting xorg or rebooting you should be able to start xorg. Use sudo nvidia-settings to further configure screen(s). For more info see

If this doesn’t solve the issue perhaps I missed something, for laptops these steps will not be the same.

Hello, and thanks for the replies!

Unfortuanely none of these solve my problem i still cant boot after installing nvidia driver.

What nvidia packages do you have installed?

pacman -Qssq nvidia

I would post from terminal output fron inxi -G , might help a bit, never know.

I installed the packages you said, is there a way i can save output from the terminal because now when i cant start x i dont know how to copy text from the terminal when i dont have any GUI.

These are the packages i have installed


is there some package here that could cause an problem?

Natemaia asked you @inkoqnito if it was either a laptop or a desktop , might help you in here fella.

Sorry it is an desktop.

@inkoqnito , thx , might help you in there mate.

See if removing xf86-video-nouveau makes any difference.