No network connction after enabling expressvpn.service


#1

After installing expressvpn it would always tell me to restart the daemon so I added it to systemd with sudo systemctl enable expressvpn.service or sudo systemctl add expressvpn.service . After that I rebooted and noticed that I have no network connection so I was checking everything that was internet related and noticed that avachi deamon was not working and pretty sure that network-manager wasn’t working either. I enabled both of them and deleted expressvpn and reboot but it didn’t help anyone know whats going on?


#2

Please post the output of

systemctl list-unit-files --state=enabled
ip a
ip r

Thanks!


#3

yes sir
systemctl list-unit-files --state=enabled
UNIT FILE STATE
autovt@.service enabled
avahi-daemon.service enabled
ckb-next-daemon.service enabled
dbus-org.freedesktop.Avahi.service enabled
dbus-org.freedesktop.NetworkManager.service enabled
dbus-org.freedesktop.nm-dispatcher.service enabled
display-manager.service enabled
getty@.service enabled
lightdm.service enabled
lm_sensors.service enabled
NetworkManager-dispatcher.service enabled
NetworkManager-wait-online.service enabled
NetworkManager.service enabled
nvidia-persistenced.service enabled
avahi-daemon.socket enabled
remote-fs.target enabled
pamac-cleancache.timer enabled

ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 30:9c:23:07:55:41 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.32/24 brd 192.168.0.255 scope global dynamic noprefixroute eno1
valid_lft 2941sec preferred_lft 2941sec
inet6 2604:2000:5210:ee00::2/128 scope global dynamic noprefixroute
valid_lft 2939sec preferred_lft 1139sec
inet6 2604:2000:5210:ee00:b649:e5e8:4a35:62c5/64 scope global dynamic noprefixroute
valid_lft 604798sec preferred_lft 604798sec
inet6 fe80::e853:987f:795f:3195/64 scope link noprefixroute
valid_lft forever preferred_lft forever

ip r
default via 192.168.0.1 dev eno1 proto dhcp metric 20100
192.168.0.0/24 dev eno1 proto kernel scope link src 192.168.0.32 metric 100


#4

Please don’t call me “sir”, it makes me nervous :slight_smile:

It looks like NetworkManager is enabled and a connection has been made.

Can you ping?

ping 8.8.8.8
ping google.com

If the first command works but the second command fails then please post the output of

cat /etc/resolv.conf

#6

I can ping 8.8.8.8 but can’t google.com the output of cat /etc/resolv.conf/ is
# Generated by expressvpn search expressvpn nameserver 10.191.0.1
I think I see the problem here lol

also sorry for calling you sir,sir :grinning:


#7

Yeah, that won’t work without the VPN running :slight_smile:

I’m surprised NetworkManager doesn’t overwrite that with the correct value but you can do it yourself:

sudo tee /etc/resolv.conf <<<"nameserver 192.168.0.1"

^ That sets your router (and hence ISP) as the DNS, you can use other options if you want:

https://en.wikipedia.org/wiki/Public_recursive_name_server#List_of_public_DNS_service_operators


#8

thx man your the best