No login screen after installation - LightDM Openbox

Hey team! After completing the installation I get this screen.
I have reinstalled xorg and ligthdm packages with no luck.
Also, I have searched the forun for a solution but had no luck.
i can login through another tty but no X can be run with startx since the command seems to be lost and cannot be found by the interpreter.
What do you think?

did you sudo systemctl enable lightdm.service

1 Like

What is the graphics card?

lightdm may be broken. Log in on different tty and install xorg-xinit to get startx installed.

Yes, the service is enabled by default… I tried to disable it and I get a console login. All ok there but I cannot start the window manager after login through console

I am using an intel graphics card on an old Thinkpad T61. This installation is on qemu/KVM with a qxl driver. I tried to run X :0 -configure but there is an error I can figure out. Then tried to run xrandr and another error jumps Can't open display

Any useful information in the log file mentioned before xinit quits?

1 Like

I found that changing QXL to VGA in the Qemu/KVM options let me get to the login screen, so I have to fix the installation to manage QXL drivers. But another issue is arriving there… After typing the right credentials the screen resets so the user can not enter the session from there.
If I open a new console, do login and then execute startx, the following screen appears:


Any sugesstion?
Thanks for the help!

Welcome here ! Have you try an install with another DM ?

That looks like the screen displayed if startx/Xorg does not know what window manager you want to start.

Check that you have a ~/.xinitrc and that it’s properly configured to start your window manager.

Which window manager are you trying to use?

Hi there. I haven’t tried with another DM. I like the clean desktop and the complete keyboard setup that ArchLabs had achieve with openbox.

@PackRat I’m using openbox with lightdm. I’ll check if there is a .xinitrc file, if not I guess it should be created manually and add the proper configuration to allow X to start the DM automatically after login.
The image I shared before shows what appears after I do startx in a tty2.
I think that not being able to login can be related to accountsservice too, but maybe I’m wrong…

I used to have an issue where LightDM would not appear, and that was due to my SSD being too fast and it would blow past Grub. I just edited a line in the etc folder, the LightDM config. I forgot which like I edited - hold on - it was this:

logind-check-graphical=true

And that fixed it.

2 Likes

That s a good tip in there @drummer

1 Like

It’s in the Arch Wiki, although I find that wiki a bitch to follow lulz.

1 Like

Yep, it s faster when you look up @drummer s tip ! lol

1 Like