No loader entry for LTS kernel

After completing the archlabs installation with the zen kernel I’ve decided to install also the LTS kernel.
but now in the directory loader/entries there is just a file archlabs.conf with the zen kernel
there is no LTS kernel entry

in the boot menu there is just the zen kernel entry, no LTS
how could I add the LTS entry?
thanks :slight_smile:

1 Like

I tought that it could be installed ( optional ) when installing AL itself.

2 Likes

Did you update the grub?

https://wiki.archlinux.org/title/GRUB

# grub-mkconfig -o /boot/grub/grub.cfg
4 Likes

yes, but I’ve installed the LTS kernel later, after I’ve finished the archlabs installation

I forgot to write that I’m not using grub, but systemd boot :slight_smile:

Oh, makes sense @quo , I use grub, so can t be of any help concerning systemd kernel management & such.

Found that link, hope it can be of any help;

2 Likes

You need to make another lts.config in /boot/loader/entries/.
Copy your linux.conf to (what ever).conf and edit it for the lts version.

EDIT: Working arch-lts.conf for my computer ONLY!

title   ArchLabs Linux LTS
linux   /vmlinuz-linux-lts
initrd  /initramfs-linux-lts.img
options root=PARTUUID=5d3a4c7d-00ac-49eb-a0f3-dcc5259f89ce resume=PARTUUID=5d3a4c7d-00ac-49eb-a0f3-dcc5259f89ce resume_offset=34816 rw 
5 Likes

thanks a lot :smiley: really
problem solved

1 Like

Oh, I m surprised that @sammiev s solution worked ! Props to you sir !

A good thing I must say ! Glad that you got it to work @quo

1 Like

I like my systemd-boot.

3 Likes

Looks too complicated for an old fart like me ! lol

I must say that I m too used with GRUB.

2 Likes