No Gui (openbox) and DM after installation


#1

Im Installing the ArchLabs 2018.12.01 on virtual box, after installation I faced the post installation problem where the ping github.com did not work and the script did not run. I commented the connection option as suggested and installed with LightDM and a few other applications.
But when i rebooted a basic login screen, once i give the login details im taken to

. I searched online and found to use ‘startx’ which works for me.
But after using it LightDM is not displayed. And I also started the LightDM services and rebooted and the same problem persists. I also tried changing ~./xinitrc file which I was unsuccessful with too. Is there anything I missed during the instillation? How can i solve this ?


#2

Try reinstalling your chosen desktop again and try startx.


#3

I did that more than twice. Still the same thing happens… :no_mouth:


#4

If you installed lightdm, you wouldnt be using .xinitrc
I see that you started the lightdm service. Double check to see if it actually working
ps ax | grep lightdm


#5

6299 pts/0 S+ 0:00 grep --color=auto lightdm this is the output for ps ax | grep lightdm.


#6

You should see something like this:

1071 ? SLsl 0:00 /usr/bin/lightdm
1077 tty7 Ssl+ 6:56 /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
1186 ? Sl 0:00 lightdm --session-child 12 19
26914 pts/2 S+ 0:00 grep lightdm

If not - the service is either not running or lightdm is not installed


#7

this is all i see


#8

Try this:

sudo systemctl enable lightdm
Then
sudo systemctl start lightdm


#9

Failed to enable unit: Unit file lightdm.service does not exist. Does this mean I did not install it? But I did so what do you think happened?


#10

Try this;
ls -al /usr/bin/lightdm

-rwxr-xr-x 1 root root 280432 Sep 10 09:40 /usr/bin/lightdm

If there isnt anything - its not installed


#11

It does not exist. I mean it seems not to be installed im pretty sure I typed ‘y’ when al-hello prompted me about installing LightDM. so what do i do now install lightDM?


#12

sudo pacman -S lightdm


#13
pacman -S lightdm lightdm-gtk-greeter lightdm-gtk-greeter-settings

systemctl enable lightdm.service

reboot

EDIT: what @chris60601 said will work too, and you can pick a greeter you like or stick with the default


#14

I guess I should have also mentioned that if you really didn’t want to install lightdm as an alternative, if startx was on your sytem - adding “exec openbox &” (without the “”) as the last line in .xinitrc would work also if you wanted to boot to console and manually start openbox. by typing startx. I just assumed you wanted to stick with a login manager.


#15

should I see the Login manager after that? or will i still be prompted with the basic interface(dont know what its called black screen with the archlabs login: on it ) ? The basic Interface is what i see and then back to the same terminal interface again no openbox.


#16

The & is redundant in this case as exec forks the process, sound advice though :slight_smile:


#17

Yea of course id want to use the login manager.


#18

Once lightdm is installed as natemaia mentioned, you’ll need the enable the service.
Then a reboot should give you a GUI login

sudo systemctl enable lightdm.service

reboot

#19

I tried it dint work for me and also tried adding exec openbox & on an other reboot and now startx dosent work and vim shows it dosent have a dependency installed what other editor do i have?


#20

nano is another editor you can use. I’m wondering if there is something odd about your video card and perhaps your Vbox is doing something odd about it.

Other than that - unless you dont have xorg installed (and I doubt that would be the case). Not much more I can offer.