New Laptop Partitioning for ArchLabs Dual Boot with Win 11

How would you resize it @Judd?
I am thinking of just using the free version of AOMEI Partition Assistant Standard but am wary

Although I dont have a ‘microsoft reserved partition’ on the Win 11 like in Win 10, so maybe it will be easier?

Man that sounds like a really cool laptop. I’d wipe the drive and get linux wierd, but don’t listen to me. Nowadays with thinkpads there is not a lot of reason though for windows unless you need to install something on there and you can always reinstall (yours might be to new for that approach), the windows key is in the uefi bios usually. fwupd seems to be able to update the bios better than windows on my T15. Like I said don’t listen to me, works on this model.

1 Like

I was correct to be wary:

It seems there is a 16 MB partition between EFI and Win partitions (probably the reserved partition but I cant see it in Windows disk manager) which the AOMEI free tool cant move

► How to increase EFI partition in windows 11, 10, 8, 7?

If there is unallocated space on the right or left side of the EFI partition, you can use the “Resize Partition” feature to realize Windows 11 increase EFI partition size.

But …

:writing_hand: Note: If there is not any unallocated space on the hard drive or the unallocated space is not adjacent, you can upgrade to the Professional edition, which comes with the “Allocate Free Space”, allowing you to directly transfer free space from one partition to another only in 3 clicks.

But they have to make their money I guess

does yours have the i5 or 7?

Thanks @cog , its the best I have ever owned - love it to bits

If it wasnt for the need for Office for co-writing Journal papers and FEA and other software for work - I wouldnt have windows for sure

I have tried all the alternatives (and use LibreOffice at home for example, FreeCAD etc etc , but it just doesnt work as well / makes my life more complicated than just having Dual boot

Its got the 7,
In for a penny in for a pound - I cant afford either :rofl:

1 Like

I have a docker based onlyoffice solution I use. Seems to be super MS office compatible. Will share with you down the road. You got other fish to fry ATM.

Bugger, all my notes and posts seem to just tell me how to remake the EFI partition in case of corruption.

But I cant find out how I increased its size

Office 365 or Google Docs. Far, far away from any local drive.

1 Like

Apparently Gparted now can resize an MSR (MS reserved) partition :+1:

First, got my Windows key just in case

How to Find Your Windows 11 Product Key using CMD

  • Click Start icon, type cmd in the Search box, right-click Command Prompt and select Run as administrator.
  • In the Command Prompt window, you can type the following command: wmic path SoftwareLicensingService get OA3xOriginalProductKey. Press Enter to execute the command and it will show your Windows 11 product key.

And I have disabled Secure boot, Fast Startup and Hibernation wasnt enabled

First boot from ArchLabs USB :grin: :grin: :grin: :grin:

Live session very helpful

Installed GParted

but …

Windows Partition is ‘bitlocker’


Now to disable that in Windows

OK, so I am now there with the partitioning :grin:

Now that Gparted can move that MSR partition, resizing the EFI partition is easy
I made it 1 Gib to be safe
Well, I tried to make it exactly 1024 GiB but due to alignments in GParted it ended up as 1022 MiB with 2 MiB unallocated after it (in case this is relevant to what is to come below)

So, now I have:

or in Windows (which still works - bonus!)

But …

Now running the ArchLabs installer (archlabs-2023.01.20-x86_64) from a USB stick gives me an error :frowning:

I set up the install with my well-tested setup:

But I get this error on the setting up GRUB bit (I presume):

error cannot find a GRUB drive for sda1.  Check your

Anybody have any ideas, please?
Windows is still fine

Getting there, step by step :grin:

EDIT: I am not sure if this is related, but after a failed install, when I try to reboot from the AL stick it fails to boot with the following:

If I simply re-flash the ArchLabs iso to the USB stick (using gnome-disks on my ASUS) then it works again and I can boot from it

Is it something to do with no boot flag on my 1022 MiB EFI Partition?
But in the GParted screenshot in the post above above
It says ‘boot’

Ah, always learning, the boot flag is not there in the above because its GPT, but it is for parted (and hence GParted):

But on the ASUS the EFI isnt flagged as ‘hidden’:

Or, maybe I was stupidly selecting the USB AL installation stick EFI partition sda1 as the boot partition for my installation on the laptop (hence why I had to keep re-flashing the USB stick)

Perhaps this should be moved to ‘make me laugh’ / or I should start a ‘tw@t of the year’ thread?

Oooohhhh Yeeeaaaahhh!
I made that fucking difficult or what!

Interesting, I was pretty sure the installation media partitions were removed from the lists. Glad you got it figured out.

Also of note is that I have several laptops that I dual boot with windows and I’ve never had too many issues fitting the AL boot and windows boot on the same 260M EFI partition. If you start doing various distro installs and never clean the EFI part then it will become an issue, in this case going in manually and removing dead bootloaders is the best option.


@leigh thats glorious. Hey does your usb-c power cord feel a little wobbly in the first port but tighter in the 2nd? Wondering if it’s just my T15 or they’re all like that.

Thanks @natemaia
Oh. So I would have probably been OK with the 260 MiB
But at least I learnt that expanding the ESP is now easy now that Gparted can do that
And I can install another couple of dozen OS’s with no worries now :rofl:

But I’ve done all the distro hopping I need, I’m sticking here with AL. And I have a pile of old laptops for that in case I succumb to temptation

It is indeed Glorious!!!
The power cord in the usb- port on mine is wobbly in both ports. I use the red clip with the ‘legs’ pointing down on the desk like a ‘stress reliever’
Why do they have two?
what else can I use it for?

I’m almost all set up again now
Joplin-Desktop is the only thing that doesnt seem to be playing ball

The trusty ASUS was a good old stead for years, but this thing is a different order of magnitude, even the touchpad is so silky. Mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm!!!

1 Like

shit, the speakers even have bass :smiley:

I use the red clip like a kick stand too sometimes! The 2nd port is for a usbc docking station. But you can use both ports for charging or data or whatever.

1 Like

:rofl: I didnt even know what Thunderbolt 4 were