New installation, no chosen packages installed (solved)

#1

Have tried reinstalling a few times selecting different options, but each time i just end up at shell.

pacman -Q shows none of the packages selected during install, including xorg.

I don’t know if would make any difference, but i am using a home directory from my previous linux distro.

Edit: checking pacman.log i find this entry

[2019-05-02 06:17] [PACMAN] Running ‘pacman -S --needed --noconfirm archlabs-scripts archlabs-skel-base archlabs-themes archlabs-dARK archlabs-icons archlabs-wallpapers base-devel xorg xorg-drivers sudo git gvfs gtk3 gtk-engines gtk-engine-murrine pavucontrol tumbler playerctl ffmpeg gstreamer libmad libmatroska gst-libav gst-plugins-base gst-plugins-good openbox bspwm fluxbox xfce4 obconf archlabs-skel-openbox jgmenu archlabs-polybar tint2 conky rofi lxmenu-data sxhkd archlabs-skel-bspwm rofi archlabs-polybar menumaker xfce4-goodies xfce4-pulseaudio-plugin network-manager-applet volumeicon rofi archlabs-skel-xfce4 xorg-xinit firefox geany mousepad thunar pcmanfm gparted file-roller xarchiver xterm tilda xfce4-terminal vlc mpv deadbeef clementine evince gpicview transmission-gtk gnome-disk-utility gnome-system-monitor qt5ct steam docky qt5ct qt5-styleplugins zsh-completions zsh-history-substring-search arandr archlabs-networkmanager-dmenu xdg-user-dirs nitrogen polkit-gnome volumeicon xclip exo xdotool compton wmctrl gnome-keyring dunst feh gsimplecal xfce4-power-manager xfce4-settings laptop-detect archlabs-ksuperkey’
[2019-05-02 06:47] [PACMAN] Running ‘pacman -S lightdm lightdm-greeter lightdm-greeter-settings’
[2019-05-02 06:48] [PACMAN] Running ‘pacman -S lightdm’

So it looks like the install script attempts to install my selected packages, and nothing happens, the next entry is myself attempting to install lightdm manually.

1 Like
#2

Welcome to the forums @fluxx.
That is odd, let me do some digging. I do know installing any distro into another distro’s home directory is going to cause issues. But I don’t see how it would prevent package installation…let me use some google-fu to see whats up.

1 Like
#3

Hi Mr Apple

just an update that may be of use

I’ve tried entering the pacman string manually, with and without the --needed --noconfirm commands, and all that happens is packages that i’ve installed myself get reinstalled, so i’m going through each one installing one at a time, about 1/3 of the way through the list and each one has installed without issue so far.

Also the first one, archlabs-scripts was already installed.

#4

Very odd. At least your getting it done. I still wonder what happened.

#5

Did you create a new user with the archlabs install script?

As long as the username and group settings are matched from your previous linux installation you should be able to chown the home directory to your user. Not entirely sure though, this is just a guess.

So it would look something like this from the root account.

# chown -R username: /home/user/

You wouldnt create a new user with a new home with archlabs if you wanted to keep the previous linux installations home though, you would create a user after a root only installation and then manually add in a user to match the wanted home directory.

Arch wiki can explain it better than i can…

https://wiki.archlinux.org/index.php/Users_and_groups#Overview

#6

Same user name, different password, not sure about the group settings.

I mainly kept the old home directory to save having to move files around, and partly to see what would happen, but for the sake of trying to shed light on this issue i think i’ll create a fresh home for this install and see if that makes a difference.

#7

create a new user and home directory and see what happens, you can always delete that user later on.

# useradd -m -G wheel -s /bin/bash/ username

# passwd user

#8

I’ve already hit the big red button i’m afraid, formatted and done a clean install.

After comparing what i had to what an install of archlabs should look like it was clear that things were not configured correctly even after manually installing everything, so felt if i did get the cause figured out i’d probably always have doubt that something wasn’t right.

Looks like after nuking my old home directory everything has installed and configured correctly.

Thank you very much for your help though.

1 Like
#9

solved then.

#10

hello @fluxx welcome on board!

1 Like
#11

Thanks @pippo i like what i see so far, may be here a while.

1 Like