ArchLabs Linux

New Install of ArchLabs boots OK but only to command prompt

Hi, this is the first time I have installed ArchLabs and after reboot, it seems to load ok but only boots to command prompt…

Arch Linux 4.19.56-1-lts (tty1)
Archlabs login:

I did choose Xfce as a desktop during the installation so I was surprised to not see the desktop.

I have used linux for a couple of years and have tried Mint, Debian, Manjaro and Antergos. So I have a little experience but not sure where to go from here.

Any advice would be appreciated. Thanks

Can you log in?

Did you try and install a display manager like lightdm? ArchLabs does not install a display manager by default.

If you can log in, try starting your xfce4 session with:

startx

if that doesn’t work, check that startxfce4 is an option in your ~/.xinitrc.

And welcome to the community, enjoy ArchLabs.

[quote=“PackRat, post:2, topic:3371, full:true”]
Can you log in? [/quote]

                         **Yes**

[quote=]
Did you try and install a display manager like lightdm? ArchLabs does not install a display manager by default.[/quote]

		I didn't notice that during the install steps, can I just enter...

		**$ sudo pacman -Syyu lightdm**

		Is there any config? I saw this url...
		https://www.addictivetips.com/ubuntu-linux-tips/set-up-lightdm-on-arch-linux/

		Do I need to follow all the steps on "addictivetips" link?
		I tried but got message...

		**-bash: startx: command not found**

		I tried "sudo startx" but got message...

		**sudo: startx: command not found**
		I tried "nano ~/.xinitrc" but got message...

		**-bash: nano: command not found**

I’m not too good in terminal as you can see. Any clue where I made the mistake?

I managed to install nano and opened …

~/.xinitrc

but can’t see startxfce4 as an option

how to I add this?

It can vary depending how (which) .xinitrc got installed, post the entire contents.

or if you want, you can use pacman to install lightdm and go with the default setup. I’m assuming there is a /usr/share/xsessions/xfce4.desktop file to work with lightdm.

Looks like startx didn’t get installed. I think that gets installed as part of xinit if you want to use pacman to install that as well.

hi,
try this command on tt1
cp /etc/X11/xinit/xinitrc ~/.xinitrc
add this in .xintrc :
exec startxfce4
and reboot

Hi PackRat, thanks for your reply, I entered the following…

$ sudo pacman -Syy

$ sudo pacman -S lightdm # looks like it installed OK

$ sudo pacman -S xinit # message… “error: target not found: xinit” so checked google…

$ sudo pacman -S xorg-xinit # did you mean this package? looks like it installed OK…
# landed at the command prompt, then message says…
# “[ OK ] Started Daily man-db regeneration”
# …with blinking cursor on next line

$ sudo shutdown -r now

still boots to tt1

login

$ startx

xauth: file /home/hugh/.Xauthority does not exist
xauth: file /home/hugh/.Xauthority does not exist

… new post from ector …

hi, try this command on tt1

cp /etc/X11/xinit/xinitrc ~/.xinitrc

add this in .xintrc :

exec startxfce4

and reboot

… end post from ector …

so i entered the following commands…

$ sudo cp /etc/X11/xinit/xinitrc ~/.xinitrc

$ sudo nano ~/.xinitrc # added this “exec startxfce4” to end of file

$ sudo shutdown -r now

still boots to tt1

login

$ startx

screenshot of the “startx” command…

Thanks for all the support.

I’m a bit lost tbh, does any of above give you a clue what is wrong with my installation?

FYI: also noticed my keyboard should be UK GB ,but it’s something different even though I did select the correct keyboard during the installation, so not sure what went wrong.

try

startxfce4

or

sudo pacman -S lightdm-gtk-greeter

and then

sudo systemctl start lightdm

1 Like

Thanks for your patience archus, my results of above…

$ startxfce4

-bash: startxfce4: command not found

$ sudo startxfce4

sudo: startxfce4: command not found

# so try....

$ sudo pacman -S lightdm-gtk-greeter

# looks like it installed OK

$ sudo systemctl start lightdm

# what looks like a desktop appears 
# with username and prompt for password
# but when I enter my passwork, 
# message says "Failed to start session"

so click restart from menu at top RH of desktop

boots to tt1

login then enter once again…

$ sudo systemctl start lightdm

# same result as before, enter password and message says "Failed to start session"

see screenshot of desktop login…
ArchLabs-screenshot-desktop

Thanks again for your help, we have some progress but something still isn’t right, I’m not sure of the cause of the problem.

Looks like xfce4 didn’t get installed. You can use pacman to install/re-install.

Well, why don’t you reinstall xfce ?

sudo pacman -S xfce4 xfce4-goodies

surely something when wrong during install
ps: never login like this sudo startxfce4

Looks like the installer didn’t install a window manager for you. Everything else appears to be working.

I don’t think you have xfce4 installed.
you have also created your non-root user, because ligthdm is useless if you have not created your non-root user.
in fact it asks you for username and password

thank you all for your continued support, I entered the following…

$ sudo pacman -S xfce4 xfce4-goodies

:: There are 16 members in group xfce4:
:: Repository extra

  1. exo 2) garcon 3) gtk-xfce-engine 4) thunar 5) thunar-volman 6) tumbler 7) xfce4-appfinder 8) xfce4-panel 9) xfce4-power-manager 10) xfce4-session 11) xfce4-settings 12) xfce4-terminal 13) xfconf 14) sfdesktop 15) xfwm4 16) xfwm4-themes

Enter a selection (default=all):

   # I entered to select all

   #  reboot and login on tty1

$ startxfce4

# Xfce desktop opens, select "use default panel"

# I had to add WaveLan item to the application panel to see status of the wireless network.  which connected automatically, so password entered during installation was remembered.

    # when I reboot again I still need to login via (tty1) then enter ...

$ startxfce4

… to start the desktop

I’m not sure how I can automate the desktop to come up at boot. any ideas?

You mean auto start the xfce4 desktop when you log in?

That use to be the deafult for ArchLabs. Search the forum, I think there’s a thread detailing how to do that.

@fracmo2000

LOOK HERE:

https://forum.archlabslinux.com/t/for-all-you-security-conscious-people/3063/24

Quick note:

^ Never update the package database then attempt to install a package without also upgrading the entire system, it is possible to break Arch-based machines doing this.

Always use

pacman -Syu $package

See also https://wiki.archlinux.org/index.php/System_maintenance#Partial_upgrades_are_unsupported

It still is to the best of my knowledge, not working on it anymore but you would have to select to not autologin in order to get here.

1 Like