New install ArchLabs 2020.05.04 on UEFI system - cant mount partitions during install

Has created LVM on LUKS

When chosing mount parttions step 5 after creating lvm it exits installer for me with the line:
line 1282 -1: substring expression < 0

What am I doing wrong?

It will be an ISO problem, wait for @natemaia or others who will be able to give you an answer.

Hello and sorry for the issue.

Try running this before starting the installer

sed -i 's/isize=${s:0:-1}/isize=${s:0: -1}/g' /usr/bin/archlabs-installer

Also, would you mind posting you’re actual partition layout? After some trying I’m not able to reproduce this and having a layout of what size partitions were used and where would be really helpful

Its a dual boot system. But I noticed now that I tried your command that I cant create the lvm. Nothing happens when I chose Create Volume Group and Volume(s). But if I reboot and then go straight to lvm I can create the lvm but cant mount partitions.

Try running these two commands before installing:

mkfs.vfat -F32 /dev/nvme0n1p1

(your GRUB partition; change the directory if necessary)

mkfs.ext4 -q /dev/nvme0n1p5

(your ROOT partition; change the directory if necessary)

having the same issue I am gettingthe same error as describerd on the first post
try to do the sed and dint work

my disk config is

  • 501M on /mnt/boot
  • 476.5G on /mnt

the 475.5G has a Luks encr

Did you try the latest version of the installer?

pacman -Sy archlabs-installer

I think it’s up to v2.1.61 (last updated 2020-06-28).

1 Like

very good question,
when i did upgrade archlabs installer while i was on the booted in the Live Iso, it removed the archlabs installer and it didnt replace it :confused:
downloading the latest tar with the archlabs installer and untar it, it gave me a file in /usr/bin/installer ( which was not installed by pacman ( maybe a bug :confused: )

Running the new /usr/bin/instaler worked fine , but now i have issues with Refind finding my kernel ( which might be me doing something weird with my partition order etc , different topic )

The executable was renamed to just installer. Regardless of that, I highly doubt pacman failed to upgrade if it said it succeeded.

1 Like

@natemaia that seem to work , didnt realise new installer changed name, I was waiting for the same name
Also good work for the new installer :slight_smile: has everything and is not as complex

Yep it seems to work if you update to latest installer. @natemaia.

Sorry for the slow reply I went off and installed arch the wiki/blogg way.

Best regards