New Google AL-iso problem

@natemaia I tried the download install iso from your google drive… I am unable to select my newly created partition for installation (created using gparted). The install simply loops. :frowning:

Please make sure the installer is up to date using

nmtui-connect
pacman -Syy archlabs-installer # should be 2.1.38

If you still have the same issue after then we can deal with it here.


Should be a new official release by the end of the day if all goes well.

Yesterday I did the install following those steps and it worked fine

1 Like

Install is in process… update to the installer was completed prior to my current build. More soon.

@natemaia The install with the update worked (sort of); I still hang if I install using LightDM(weird). My system hangs on login; this seems to be an arch feature. Debian does not experience the same 1+ minute hang… I reinstalled with SDDM and the install abends on the following command with no error:
chrun 'pacman -S sddm bash intel-ucode linux -noconfirm --needed

Next I’ll try with GDM and then .xinitrc options selected.

EDIT:
You’ll be happy to see gdm throws the same error…

chrun 'pacman -S gdm bash intel-ucode linux -noconfirm --needed

EDIT edit:
You’ll be really happy to see xinit setup throws the same error…

chrun 'pacman -S xorg-xinit bash intel-ucode linux -noconfirm --needed

Edit…edit…edit
And lastly, archlabs-LY throws exactly the same error/ problem. Now I’ll go to the machine with all the problems and get the inxi info for you.

Here’s the inxi -Fxxxz output from within my MXLinux partition.

mark@mx:~
$ inxi -Fxxxz
System:
Host: mx Kernel: 5.4.0-3-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0
Desktop: Xfce 4.14.2 tk: Gtk 3.24.5 info: xfce4-panel wm: xfwm4
dm: LightDM 1.26.0 Distro: MX-19.1_ahs_x64 patito feo February 15 2019
base: Debian GNU/Linux 10 (buster)
Machine:
Type: Laptop System: Dell product: Inspiron 5493 v: N/A serial:
Chassis: type: 10 serial:
Mobo: Dell model: 0M4FW1 v: A00 serial: UEFI: Dell v: 1.3.0
date: 10/24/2019
Battery:
ID-1: BAT0 charge: 39.9 Wh condition: 39.9/42.0 Wh (95%) volts: 12.4/11.4
model: BYD DELL 1VX1H9A type: Li-ion serial: status: Full
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510
serial: charge: 55% (should be ignored) rechargeable: yes
status: Discharging
CPU:
Topology: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP
arch: Ice Lake rev: 5 L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 19046
Speed: 2060 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 647 2: 1593
3: 626 4: 1001 5: 913 6: 1128 7: 894 8: 1359
Graphics:
Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:8a56
Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
compositor: compton resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics (Ice Lake 4x8 GT1)
v: 4.6 Mesa 19.3.3 compat-v: 3.0 direct render: Yes
Audio:
Device-1: Intel vendor: Dell driver: snd_hda_intel v: kernel
bus ID: 00:1f.3 chip ID: 8086:34c8
Sound Server: ALSA v: k5.4.0-3-amd64
Network:
Device-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet
vendor: Dell RTL810xE driver: r8169 v: kernel port: 3000 bus ID: 01:00.0
chip ID: 10ec:8136
IF: eth0 state: down mac:
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Dell driver: ath10k_pci v: kernel port: 3000 bus ID: 02:00.0
chip ID: 168c:0042
IF: wlan0 state: up mac:
Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-10:5
chip ID: 0cf3:e009
Drives:
Local Storage: total: 953.87 GiB used: 542.76 GiB (56.9%)
ID-1: /dev/nvme0n1 vendor: Silicon Power model: SPCC M.2 PCIe SSD
size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 serial: rev: ECFM22.5
scheme: GPT
Partition:
ID-1: / size: 58.94 GiB used: 7.92 GiB (13.4%) fs: ext4
dev: /dev/nvme0n1p2
Sensors:
System Temperatures: cpu: 77.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0
Info:
Processes: 240 Uptime: 1m Memory: 23.33 GiB used: 988.5 MiB (4.1%)
Init: SysVinit v: 2.93 runlevel: 5 default: 5 Compilers: gcc: 8.3.0 alt: 8
Shell: bash v: 5.0.3 running in: sakura inxi: 3.0.36

@spsf64, @natemaia @Dobbie03… here is the error thread that I originally started in April re: the install problem.

@natemaia @Dobbie03 I just tried using the iso install path (I used pacstrap all previous runs). It also fails. I managed to get the install to limp to the end via a missing chrun function…

Paused install and entered…

chrun 'mkinicpio -p linux'  

Resumed install to a reported successful end.
Booted the system and crashed… with the following fatal error

/lib/modules/5.6.0-arch-1/modules.devname not found

You are being dropped into emergency shell.

I give up… it doesn’t work for me. :frowning:

I am officially in way over my head.

Wonder if it s a grub issue as someone else in the forum @manyroads .

Unless that you don t use grub.

I don’t think this will work, chrun is an installer function wrapper to run commands in arch-chroot, you should just run the quoted bit eg. mkinitcpio -p linux

The mkinitcpio issue should be fixed (see my last post in the release thread).

The login packages bit is where I’m at a loss why it’s failing. Please try doing a lightdm install (wm/de doesn’t matter) and if it fails at the same point, try running (word for word) my suggestion from the other thread

Post whatever is output from the pacman command in the chroot.

Thanks @natemaia @altman I’ll give the ideas a try. After I get a new downloaded iso etc.

Hopefully it will work this time !

Not a problem, if I’m around I’ll try and chime in. Just headed to work.

Here’s what I installed:

  1. the new AL iso
  2. reformatted uefi (risky I know, but now it should be uncluttered & pristine)
  3. setup for SWAP
  4. Installed using Pacstrap
  5. went with GRUB for bootloader
  6. installed BASH
  7. installed Vanilla kernel
  8. installed 2 wms OB & bspwm
  9. installed LightDM
  10. threw a few feathers in the air, danced…
  11. There were a few file errors on downloads for paranoid, superkey, skel, common, baph, wallpapers, themes, scripts and few others I was uanble to catch as they went by.
  12. the install said it completed successfully.
  13. Rebooted
  14. Grub appeared
  15. Booting completes… The mountain appeared & screen flashed several times (10+/-) … no longing (LightDM style of other variation appeared); after 30 seconds the screen tears in half. (only 1/2 Mountain is visible), mouse is frozen (off & on)
  16. The regular lightDM appears after a about 2 minutes…
  17. Thirty seconds later it tears again.
  18. I was able to login although the screen flashes with every keystroke (during login).
  19. Once I get the tearing & freezing

The same flashing mouse freezing happens on EndeavourOS & manajaro; I’m guessing that’s some sort of Dell/arch freature. It does not happen with Debian or *buntu. The sad thing is it makes tha system unusable with AL or any other arch derivative that I’ve tried. So it goes…

If you have any idea what it might be pleas let me know.

Curious - I too had some issues (not like yours, but freezing and only a hard boot brought it back).
I too spent about a week - 10 days back in Debian without the the issues presenting itself.

What I’m wondering here, what are the diff from the video driver when you had Debian installed to what Arch* sees and installs. It could be something as easy as changing out a vid driver?

For example, on my laptop, I had to explicitly tell Arch* to use xorg-intel drivers (albeit that was some months back) and not mesa. On this system now, its an ATI card and never had an issue with any Linux install.

Just my 2-cents worth.

Mesa is not a driver, it’s an opengl/vulkan api, just a layer above the driver. Meaning Mesa will talk with whatever driver is active. Nvidia proprietary being the one exception, not sure how it works.

Does indeed seem like a driver/xorg issue though. Try removing all the xf86 drivers except intel, check the arch wiki for that cpu/igpu combo

This i5-gen10 thing is quite the pain… :wink:

Have you looked at https://wiki.archlinux.org/index.php/intel_graphics#Troubleshooting and see if there are entries/issues that are the same as what you’re getting?

I think I’ll just leave the laptop running MX Linux (Debian).