New (for me) install problem!

2020-03-02 is an older ISO; the newer ones have an option to choose how you download the packages

You have the option in the ISO setup to use pacstrap to download packages, and another option as well. Have you tried both yet?

Yes. I have tried “iso-copy” option more than twice but installer tries to connect to internet to download AL-repo and then I get intstaller error.

I tried to install on my workstation yesterday night and got the same result there too!
I do not know anything but If I guess something has happened with the mirrors the last 2-3 weeks. I really hope its temporary!

womp

Hi.

I have been having the exact same problems that womp has been having. I used the latest Archlabs on a usb made with win32diskimager and another made with etcher. I updated the installer before I tried to install. I tried to install with both pacstrap and iso-copy. I tried installing with a swap file, swap partition, and without any swap. I dropped to the counsel and tried to manually install the packages, but this ended in failure as well.

Two weeks ago, I installed Archlabs and there was no problem. I had to erase and try to install again in order to find the source of a problem I was having. All of my formatting was the same; the only thing new was that I re-downloaded the installer. I got an error msg saying there was no error. Sourceforge was giving me problems. Also, I got a not-enough disk space error, which was not true being as I tried to install on a 1tb drive that was formatted correctly.

Vanilla Arch with Openbox installed no problem. I’m located in Canada.

Install starts fine with installing kernel but after that it stops with Error. And the error-message is …“no error-message”.

I had the same problem when installing the May 4th ISO.

You need to arch-chroot /mnt and install all the listed packages you wanted to install. I had to type A LOT!!! and make sure to type them correctly.
exit and then type ‘fg’ to go back to the install and hit Fixed/Continue.

if some of the packages won’t install after typing it. just make a note to install them after you install the OS.

Don’t use the copy-iso when you are doing this ^

Yes well thank you guys for support and interest!!
I will get back to this in a week. Right now I am a bit tired of installing (trying). Have done about 50 attempts in the last days.
Sourceforge mirrors are responding a bit late and maybe it could be enough to change the time out?
I am a bit sad about this. I really like Archlabs and Openbox.
For the time being I use Arch and starting to configure Openbox.

womp

1 Like

You have some adventures in there with this one @womp

Guess that to take a break from it all might be usefull.

Yeah!
I am not giving up though, just taking a break!

womp

Some times it s good to take one.

maybe try to install Arch itself. might save you the headache

I did.

womp

Did a new install attempt.

After error-message no-error i did arch-chroot and tried to install a whole bunch of packages but got another error. could notopen file /var/lib/pacman/sync/archlabs_repo.db unrecognized archive format.

womp

1 Like

I honestly do not know what that is, but instead of installing a whole bunch of packages, just install the packages that you need to get the desktop environment running. Once you do that, install the remaining package while you’re in the desktop.

I am not sure what packages you’re trying to install that might end up giving you that message.

1 Like

Hi!
Most of the packages come from AL-repo, like skel-packages, archlabs-themes and so on.

It makes me a little worried that none of the “Creators” are looking in to this!?

womp