New (for me) install problem!

I have 3 different usb-sticks made by etcher, mint-stick, ImageWriter and 3 different downloads to be sure it’s not software-ish.

I wonder if I am the only Scandinavian Archlaber?
I find that Sourceforge is very up and down here!

womp

Try downloading from this one @womp, never know it might work;

https://sourceforge.net/projects/archlabs-linux-minimo/files/ArchLabsMinimo/archlabs-2020.05.04.iso/download?use_mirror=astuteinternet

Will do!!

womp

Hopefully it will work for you @womp

Back again!
Download of ISO went fine!

Install starts fine with installing kernel but after that it stops with Error. And the error-message is …“no error-message”.
Well I can see what the error is actually! A big bunch of packages that will not install.

I have been trying to install without internet “copying-iso” but the installer tries to connect and tries to download the AL-repo and then stops with error (no error).

I am stuck here!

womp

Do any of the solutions here help?


Specifically, this:

Hi and thanks for interest.
I am trying to install on a HP Probook 640 g1 with intel all the way. Very compatible with linux in general.
I do not get any of the error messages described above. I get one error message that says “no errors” and that is because the installer tries to download AL-repo and fails. Arch vanilla installs. Endeavour OS installs.
My conclusion is that the mirrors does not work very well in Sweden. Sweden is getting isolated is seems.

womp

OK then, have you tried using the same USB stick on another computer?

Yes. Same result.
2 weeks ago I did an install on another computer and it worked without problems.But that was 2 week ago!

womp

OK, if you got it to work before It might be settings with your laptop.
Maybe try again, with the instructions I had referenced above? The errors might be different between my problem and yours, but my solution could be a solution for you easily.
Also, some of the errors I had appear similar to yours, so my solution just might be a solution for you as well.

I am now downloading the beta-iso-2020-03-02. Is that the right one?

womp

I am not 100 % sure if AL-iso-2020-03-02 was the right one!?
I tried that anyway.
I followed the steps with bios and booting i legacy mode. I did boot fine from usb-stick (just as it did before).
Every procedure before install went well.
Install starts and after 40 sec I get an error message showing a whole bunch of packages not able to install. The error message is “no errors”.
Just the same result as before.
I still think it is Sourceforge mirrors that are very unpredictable. When I downloaded beta -iso I had to try all mirrors at least once and then try Cologne a couple of times before I got a download above 10k/s.

womp

2020-03-02 is an older ISO; the newer ones have an option to choose how you download the packages

You have the option in the ISO setup to use pacstrap to download packages, and another option as well. Have you tried both yet?

Yes. I have tried “iso-copy” option more than twice but installer tries to connect to internet to download AL-repo and then I get intstaller error.

I tried to install on my workstation yesterday night and got the same result there too!
I do not know anything but If I guess something has happened with the mirrors the last 2-3 weeks. I really hope its temporary!

womp

Hi.

I have been having the exact same problems that womp has been having. I used the latest Archlabs on a usb made with win32diskimager and another made with etcher. I updated the installer before I tried to install. I tried to install with both pacstrap and iso-copy. I tried installing with a swap file, swap partition, and without any swap. I dropped to the counsel and tried to manually install the packages, but this ended in failure as well.

Two weeks ago, I installed Archlabs and there was no problem. I had to erase and try to install again in order to find the source of a problem I was having. All of my formatting was the same; the only thing new was that I re-downloaded the installer. I got an error msg saying there was no error. Sourceforge was giving me problems. Also, I got a not-enough disk space error, which was not true being as I tried to install on a 1tb drive that was formatted correctly.

Vanilla Arch with Openbox installed no problem. I’m located in Canada.

Install starts fine with installing kernel but after that it stops with Error. And the error-message is …“no error-message”.

I had the same problem when installing the May 4th ISO.

You need to arch-chroot /mnt and install all the listed packages you wanted to install. I had to type A LOT!!! and make sure to type them correctly.
exit and then type ‘fg’ to go back to the install and hit Fixed/Continue.

if some of the packages won’t install after typing it. just make a note to install them after you install the OS.

Don’t use the copy-iso when you are doing this ^

Yes well thank you guys for support and interest!!
I will get back to this in a week. Right now I am a bit tired of installing (trying). Have done about 50 attempts in the last days.
Sourceforge mirrors are responding a bit late and maybe it could be enough to change the time out?
I am a bit sad about this. I really like Archlabs and Openbox.
For the time being I use Arch and starting to configure Openbox.

womp

1 Like

You have some adventures in there with this one @womp

Guess that to take a break from it all might be usefull.

Yeah!
I am not giving up though, just taking a break!

womp