New ArchLabs Beta ISO available for testing

That’s interesting… I have both my Hotmail and Gmail accounts on Outlook without too much trouble. Although, at one point my Hotmail account wanked out and had to tie it to a Outlook account. That was a major pain. What version of MS Office is she using? n because of this Wuhan virus or Coronavirus, I won’t be back at work till April 28th, so I might play around with this beta install and put it on metal and see what shakes.

I can not login with openbox/xfce/bspwm + ly-dm but lightdm work fine

Thanks for the info, I’ll look into Ly, possibly needs an update.

Clean install on Toshiba Laptop.

Keyboard was working OTOB - so +1 for ArchLabs; usually I have to use a kernel parameter at boot for the keyboard to work.

Everything working out of the box; partitioned before install and ArchLabs found and mounted the efi partition no problems.

Edit - everything all configured (sound etc …) no issues. Well done team.

2 Likes

Error during installation. Seems like couldn’t download base-devel, nor xorg. Happened when GNOME was to be installed, with wifi connection working properly, as I had no such problems when I went with

KDE Plasma.

Wonder if it has anything to do with this link;

You installed with KDE no issues & when installing Gnome it what s the issues come from right !

Interesting… I mean I was installing ArchLabs today from the beta ISO. I wonder that since the newest release was downloaded from the internet today, it probably would not need manual configuration from back in December…?

Hmm…

Not sure tho.

I would try it anyways, never know.

Anyways, you can do whatever you want to.

1 Like

Hello Great Team
after one month of test, i have one bug:
with my trackpad sometimes all screens for all desktop are fix. i can do nothing, there are no keyboard response.
just i can poweroff.
my laptop is a teclast f6.
Nonetheless the distribution is very clean and i work everyday with git, freeoffice, gcc without problem.
really nice release.

Thanks

1 Like

If the size of the swap partition is entered manually, i.e. what’s automatically allocated (which works fine) gets modified manually, the installation gives an error.

Doesn’t matter if the swap size is edited in megabyte, or gigabyte units.

I assume you mean swapfile, we don’t use sizes for partitions.

Is the error an installer message? eg.

Swap size must be 1(M|G) or greater, and can only contain whole numbers

I’ve tried a number of times editing the size, make sure it has M or G at the end to define the size type.

Heya Nate - you have a time line yet for an official release?

No time line as yet homie. Its the usual, its ready … when its ready :smiley:
Personally I’d like to release our new website and ISO at the same time.

1 Like

LOL - sounds like right out of the Book of Debian :wink:

:slight_smile: LOL Yes

It’s the easiest way to explain it :smiley:

1 Like

@halcek Hi. How did you solve that problem? I have the same issue since 4 days and cant install anything. Any helping thoughts are welcome!

Archlabs beta iso


Yes it is your pic. I have exactly the same error Message Screen on the beta iso.

Try dropping to shell with Ctrl-z and run the command in question (in this case just try pacman -Syyu), likely some conflicting files during update.

It’s a real toss up between having things on the live system and copying them over then updating vs full pacstrap but I think the latter is the better way in terms of reliability. When I get some free time I’ll look at adding an option to the installer

  • live usb filesystem copy and update - saves network and faster but less reliable.
  • pacstrap - slower and uses more network but guarantees latest packages at install and no conflicts.

If you want I made a new build which should work fine

1 Like

Hi. When i try Ctrl-z the error message appears again. I have tried this before with the same result.

AND> Thank you for the new build. i try the new iso out, when i have enough time.
Thank you nate!

@natemaia Just a quick feedback for the new beta iso: Works perfect!
I`m back to the game. :grinning:

Thank you for the new build of the beta iso and thank you that you can do that so quick in your spare time. RESPECT!

3 Likes

Now running the latest-latest beta, this morning with dwm and now with yaxwm. No problems with the install. At first it was a bit slow, but once the installer was working, it was like a rocket.

Thank you @Dobbie03 @natemaia and the Team!!

5 Likes