New ArchLabs Beta ISO available for testing

Nate has uploaded a new ISO for testing. Feel free to download and let us know if you strike any issues.

https://sourceforge.net/projects/archlabs-linux-minimo/files/ArchLabsMinimo/

9 Likes

Top news @Dobbie03

1 Like

I just want to remind everyone here that you’re all loved and appreciated. <3

nohomo

1 Like

Phew! I was worried for a sec.

1 Like

:sweat_smile:

1 Like

lol, good one @Dobbie03 @xstefen

1 Like

I can’t seem to find some sort of a changelog?
Not going to reinstall right now, just interested… Thanks for your hard work and the update, though!

No changelog as yet. Normally post those at release time. Basically we are really wanting to squash bugs.

1 Like

Install went smooth; some nice, new options.

Went with the -t option to install the tear free video driver. Detected the video card and offered the correct driver version - nvidia-390-xx.

X server failed to start after reboot. For some reason I have to use nvidia-390-xx-dkms driver. Once I installed that, no problem with logging into Xsession.

So I’m thinking the new -t option works for the most part - hardware glitch on my end.

1 Like

You know, I have never had a good time with Nvidia. Ever. Or was it Ubuntu that was the issue? Considering I have had ATI cards since moving to anything Arch I can’t compare…

1 Like

This is a python script we’ve used in the past nvidia-installer from the late Antergos. I can fixup issues and update where needed. If we get more issues like this I’ll switch the drivers for older XXX-xx to dkms.

Thanks for the install and feedback!


I had no issues with Arch and nvidia back when I was using one, provided I installed the driver, they also have a GUI configurator which was a plus as a newbie. Many issues with many things on ubuntu but they do things differently and that was earlier, before nvidia started supporting linux better but at that time amd/ati was no better really. Once amd opened their driver it took off and things on that side have been better on linux, amd opengl on linux is better than on windows!

1 Like

Yeah, it’s been so long since I used either Ubuntu or Nvidia. Something must have improved since.

No I wouldn’t worry with a reinstall, only real changes are fixes to older issues and additions to the installer.

I need a fresh install as testing environment. This looks like a good candidate.

1 Like

Tested the new image in QEMU/KVM, the installer failed to check internet connectivity because user-mode networking under QEMU doesn’t allow ICMP requests.

Fixed it with this patch:

--- /usr/bin/archlabs-installer.orig    2020-03-06 21:05:21.029999992 +0000
+++ /usr/bin/archlabs-installer 2020-03-06 21:11:08.573333342 +0000
@@ -2510,7 +2512,7 @@
 chk_connect()
 {
        msg "Network Connect" "\nVerifying network connection\n" 0
-       ping -qc1 'archlinux.org' > /dev/null 2>&1
+       nm-online > /dev/null 2>&1
 }
 
 net_connect()

Once that was applied the installation proceeded without further error but when I booted into the new system the X11 keymap was not set so I had to run

localectl set-x11-keymap gb

Apart from that it went well but I would have liked to be able to choose gdisk in the partitioning section, it is installed so it’s a shame there isn’t a listing for it.

1 Like

Just a tiny notice. This screen:

…tells the user that installation has been finished, and nothing happens in next several minutes. Could it say "Please wait until whatever is finished?

Apart from that - no issues.

[edit] The installer stole my swap partition and converted it into EFI. 1 GB EFI! :rofl:

1 Like

Just tried installing again and the console keymap was also not set correctly even though /etc/default/keyboard specified gb, not sure what’s going on there.

@natemaia, could you (please, please) tell me something about performance optimization you applied to ArchLabs? There’s a massive difference in nwggrid execution time in comparison to my Arch install. See “Time” [ms]:

ArchLabs, i3:

Arch, sway, i3, whatever:

image

Will change the connectivity check to this and add gdisk to partitioning tools, just out of curiosity why use gdisk over fdisk? (c)fdisk supports gpt nowadays so the g* variants are pointless.

As for the keymap, I’m not sure what happened the installer should generate

/etc/X11/xorg.conf.d/00-keyboard.conf
/etc/default/keyboard
/etc/vconsole.conf

Will need to check what’s inside them after install.