New AL user switching from Bunsen

You’ve found inner peace.

3 Likes

lol, guess so !Good one in there @PackRat

Yep! But…

Installed it but I need to sort some problems, which I suspect come with the turf when the hardware is only a few months old.

The install appeared to go fine other than I kept seeing a line appear telling me there was a problem with wifi even though I was installing with a wired connected. Turns our to be a driver or bios issue as when I finally booted into he installed system it would hang saying WLAN had issues - the system hangs with the message “BIOS contains no WRDS”.
So I disabled WLAN in the BIOS and tried again - this time no error messages but light DM failed to install - I ended up at the tty prompt.

Trying the install again I noticed that when prompted to review some some of the files at the end of the install process, clicking the last entry to review LightDM reports that ‘no file exists’.

I’ll explore further at the weekend.

Rob

What s your hardware, if possible install inxi & post results from terminal;

inxi -Fxz

Will help on what s in there.

There was another user who reported a similar issue with lightdm. I installed the latest AL on a vbox vm and it went pretty smoothly. I wonder if it’s related?

I would, as @altman suggested, install inxi from the AUR and try inxi -Fxx first to see the internet related info, then post the results of -Fxz (which doesn’t output ip stuff etc.) here if you get more problems next *time with it <3

And… you do back-ups? Hallelujah!

Thanks I’ll give that a try. TBH the wireless isn’t a concern as I use ethernet and can disable wireless in Bios. I might try a non uefi install and see if that fixes the Light dm issue, plus I see there was a discussion here recently on installing ldm post main install.

My first Arch brake has yet to come. I had more problems with manjaro than with pure arch. I always update immediately. I also have the habit of creating a disk image once a week. It takes only 8 minutes. So, if things really mess up the system and an easy fix does not exist (which mostly is not the case) I restore the latest image. As said though, it has never happened to me. I must add that I don’t use a lot of pkgs from the AUR. All in all not more than five or six. The breakages my friends sometimes have do always come from some AUR package. Arch itself hardly breaks your system.

3 Likes

What do you use to create your backup disk image, timeshift?

I run Deja-dup to back up my home folder weekly.

Every few months I make a fresh disk image using Clonezilla - in the event of a catastrophic crash and burn that gets the system back in about 10 minutes.

1 Like

I still have a paid copy of macrium reflect. One of the best, if not the best backup utility. The free version is also 100% reliable. As it is windows only you’ll have to create the bootable usb in a virtual machine. I did a lot of distro hopping. Installing on bare metal. Set the system to my liking and create a disk image. It really only takes 5 minutes. Since every distro tends to run nicer on bare metal I find this way nicer than installing a lot of VMs. My only permanent VM is windows 7 pro. Mostly for photoshop, capture one and high quality photo printing.

1 Like

Hi there. I am also a newbie to Arch. While I have been running it for 2 months, I just had one breakage. That was OBS being compiled for a newer version of qt than the one which was on the repos. I did a rollback, and I was alright. I am running on Arch and Archlabs, this happened on both systems.

1 Like

Ok, tonight I spent some time trying different install options - and we have lift off!

I’m not sure which of these measures worked but I have Archlabs installed and all seems to work.
Changes I made were:

  • Using a Toshiba instead of Sandisk USB stick (long shot but I’ve seen reports of Sandisk causing issues)

  • Using sytemd login instead of lightdm

  • Using auto-login

  • Typing a password for root user rather than leaving blank to use use the standard user password

  • Avoided selecting Qt based apps at install since I noticed a ton of errors previously when trying to download Qt dependencies - it looked like these were not available.

I selected only one DE - Openbox.

Noticed that install took much longer with far more files installed and no onscreen warnings.

I notice that the right click openbox menu contains no user selected applications other than the default browser, terminal and file manager…is that correct?
All installed programs show in the polybar launcher menu.

Boot is insanely fast - about 5 seconds from a cold boot!

Rob

2 Likes

Thanks Glenn.

Whoever themes Archlabs does a superb job.
I used to pinch the the files and tweak them a little for my Bunsen install. I see that dARK is looking very sharp indeed.

2 Likes

Right, well I’d better go load her up with my usual choice of apps and load my keybinds :slight_smile:

2 Likes

This seems to be the issue, there’s been another user that brought it to attention in another thread some time ago. Seems that a required package has been removed from the official repos (kdebase-runtime) while some of the packages depend on it, this is largely an upstream packaging issue that should be resolved eventually.

3 Likes

Makes sense.

I just installed Kdenlive and while it runs I got a warning that functionality will be restricted due to missing dependencies. The Breeze icons and default theme are also missing.

Sounds like your are trying to mix K-apps in a non Plasma/KDE environment. Have you installed all the dependencies?

Likely not as I’m used to debian/ubuntu setups. I will go search and discover :slight_smile:

1 Like

nice catch @Dobbie03.
The arch packages kdenlive page entry shows (along with other dependencies);

plasma-desktop (optional) - theme configuration

so the kdenlive devs aren’t strict on making you install all of kde if you want to use their package… nice! Maybe I’ll download it as I’ve used it before and it’s a toss up between that and blender <3

1 Like