Network Printer - rmm > AL driver conversion and install?


#1

I am trying to get my network printer up and running with my new AL install. And I have been reading from various sources, including (but not limited to) the following:

With the above referenced reading that I have done (as well as the Arch Linux Wiki and a search of this forum for my particular issue), I wish to seek help with the following:

Assuming that my best path is to convert the Linux driver for my printer (Epson WF-2630) from either an RPM package or DEB package (none being available for Arch, naturally…), how would I go about that ?

Digression: I see that this newer AL (July 2018) installs a package called Foomatic that I can also assume is fairly helpful with regard to printer support, right? However, in the handy step-by-step guide found on this page, there appears to be a reference link to a page that no longer exists, as noted above in my reference reading list.

I am hoping and have a hunch that the conversion angle is, perhaps, the most expedient, but I am not sure? I was hoping that someone, who has more experience than me, could point me in the right direction here.

Digression 2: One of the above “reading” references is actually a video about 30 minutes long. In it, the guy explains about doing an NMAP and using Gutenprint, which I did a couple of years ago in Bunsen Labs, but I thought that perhaps there was a better, easier way with this newfangled Foomatic paradigm, perhaps?


#2

The AUR has both dpkg and rpm available:

https://aur.archlinux.org/packages/dpkg/

https://aur.archlinux.org/packages/rpm-org/

I’ve never tried them though.

The download page appears to have a source package, have you tried that?


#3

@Head_on_a_Stick

Howdy and long time no see :wink:

I guess I am a bit confused? Those appear to be package managers for other distributions?! What would they be doing in an Arch distro?

Further, the dpkg' latest comments look pretty grim. And the same holds true for the latest comments regarding therpm` package manager as well.

In the past, I have seen tools that converted packages, though I can’t think of the name of one right now.

As far as a “source” file from the download page goes, I am confused? Here is a screenshot I took of said download page and all I see are .deb and .rpm files…what am I missing?

https://screenshots.firefox.com/aB09SBjwkz7PyyZl/download.ebz.epson.net


#4

Oh yes, I thought there was a .src but that’s an rpm as well, sorry!

Try installing the packages in a chroot system and then package it all up for Arch, perhaps?

EDIT: the .debs can be unpacked with ar -x and then converted manually, I think there’s even an AUR package that converts .debs to Arch packages.


#5

Not quite sure what you mean by “converted manually”? Nonetheless, I did attempt to use a package that you mentioned for aforementioned purpose…it is called debtap. However, I am getting a no go on trying to make that package initialize with…

1 r0r0@archlabs ~/BUILDER/print % sudo debtap -u                              :(
==> Synchronizing pkgfile database...
:: Updating 5 repos...
 community is up to date
 core is up to date
 extra is up to date
 multilib is up to date
 download complete: archlabs_repo        [    26.0   B  33.0B/s  0 remaining]
:: download complete in 0.78s             <    26.0   B  33.0B/s  1 file     >
:: waiting for 1 process to finish repacking repos...
error: failed to create archive reader for archlabs_repo: Invalid or incomplete multibyte or wide character
Synchronization failed. Exiting...

#6

Unpack the .deb, see what’s in it & where it goes and then replicate that with a PKGBUILD.


#7

Yeah @perchslayer, I have that issue to with debtap. I just purchased a Brother MFC-J995DW and the AUR doesn’t have my drivers yet. But I will probably break down the .deb package and use PKGBUILD or as @Head_on_a_Stick suggested ar -x when I get back to my computer.


#8

Well, as of yet, I am not well versed enough to accomplish that task, so maybe I am not AL material quite yet.


#9

Sometimes, @perchslayer, we all may think that we are not Arch or AL material. But, why not try to use the suggestions that @Head_on_a_Stick suggested. Sometimes you have to try things even at the risk of having to reinstall a system that gets messed up. I don’t think that there isn’t one person on this forum that hasn’t have to reinstall when experimenting. That’s one of the things about Linux systems, is that you are given the chance to experiment and explore. Experiment, mess up, reinstall, and repeat.


#10

The source packages appear to be in that epson-printer-utility-1.0.2-1lsb3.2.src.rpm -
Unpack that rpm and there are:

epson-printer-utility-1.0.2.tar.gz
epson-backend-1.0.1.tar.gz

an Arch package can be built from those can’t it?


#11

Yes, indeed it can :slight_smile:

That seems to be how the various AUR packages do it, the OP could use one of those as an example to work from:

https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=epson-inkjet-printer-201101w

EDIT: does the generic Epson printer package not work?

https://www.archlinux.org/packages/community/x86_64/epson-inkjet-printer-escpr/


#12

You can also use:

sudo dpkg --add-architecture i386 (if the package you’re installing i386 onto a 64 bit machine)

sudo dpkg -i <package name>

This will install .deb packages as well. Yes, I know that you are not comfortable with this, but your printer will be installed, while you make your PKGBUILD.