Network-manager not installing

I did a clean installation from the new ISO and network-manager was not installed, network was running fine on the live ISO but when i rebooted there was no network, so I thought no problem ran nmtui, and it would not start because network manager was missing.
Any ideas is it an arch problem, maybe i will wait a few days and try again see if it works then

1 Like

How bout this command in terminal;

What results do you have .

pacman -Ss network-manager

It says it’s installed ah it’s installed but it’s not auto starting

Hey thx, can you post the results please as it can help in one way or another, some might check it out & give a hand.

What s your hardware & what did you installed might also help.

Also, if you type in this, what it does;

nm-applet

I ran this command and connected now

sudo /usr/bin/NetworkManager --no-daemon
`

Good, hopefully will be ok after reboot !

Also check the output of this command;

systemctl status NetworkManager


It has not auto started I will have another try tomorrow after work I need to sleep now

Hey cool, have a good sleep !

sudo systemctl enable NetworkManager.service

reboot

7 Likes

Thanks @judd

1 Like

@Kamu there was a problem with the installer because arch removed a couple packages between when we last released and when you did your install. We fixed it and it should work good now.

Thanks I Will have another look on my next free day

1 Like

The fix is in the installer just to clarify.

1 Like

Just update the installer I would think ! What s the command for some members in the future if needed.

Just run the installer; it updates itself.