Network manager daemon high cpu usage [SOLVED]


#1

Network manager daemon eats one core of my CPU. I’m on i3 Gaps, system is updated.

Shall i wait for the update to fix things or is there something i could do myself?


#2

What s the Network Manager s version @eesau

Edit: wonder if it s linked with avahi, I have read somewhere that it s hard on memory.


#3

It’s version 1.14.5dev+17+gba83251bb-2

But for some reason it’s ok at the moment, no extra CPU usage after i rebooted. Rebooting didn’t help earlier though… I’ll keep an eye on it.


#4

Yep , keep us posted, results looks weird right !


#5

Hi @eesau, maybe this wiki may give you some ideas of wht is causing the high cpu usage:

High cpu usage causes and effects


#6

Thx for that, haven t tought about it @sevenday4


#7

Yes, Arch Wiki is just great.


#8

Remember to check the systemd journal for any relevant messages:

journalctl -r

^ This will show the entries in reverse order.

I’ve never liked NetworkManager anyway, netctl & systemd-networkd are “lighter” alternatives, see the ArchWiki for configuration details if you want to try them.


#9

If the computer uses a wired connection and doesn’t move around much you could just use dhcpcd which is what I use, you can just uninstall networkmanager and enable dhcpcd.service

Edit: fixed spelling error (dhcpd -> dhcpcd)


#10

That sounds good, i’m going to try it.

Yes, i have wired connection from my router.


#11

Yep, that’s works fine. Thanks. :+1:

Though it was dhcpcd.service that must be enabled.


#12

I just posted a announcement about this. Its an upstream issue with NetworkManager.

https://bugs.archlinux.org/task/61688


#13

Thx , will check it out.


#14

Is it possible to use dhcpcd with VPN? I noticed that my (Nord)VPN didn’t work with it, at least out-of-the-box. Had to reinstall networkmanager.

These network things are out of my league. :yum:

EDIT: Typo


#15

Did you install openvpn so that you can use Nordvpn? Cause I had to to get Nordvpn to work on my system. This is the one that I used:

openvpn-nordvpn


#16

Ah, now it works with dhcpcd also. I don’t know what happened… Oh well.

sevenday4, i haven’t got openvpn-nordvpn installed, only nordvpn-bin.