My kernel upgrade problem

This happens with my last 3 kernel updates, I know I messed up something. Just going for a normal pacman -Syu I’ll end up with the error replicated bellow:


Because in my /lib/modules I have 5.9.13-arch1-1, so it works if I run:
mkinitcpio -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img -k 5.9.13-arch1-1

Any idea where to fix this so I can do a normal upgrade next time without having to do this manually?
My linux.preset is pretty bare:

# mkinitcpio preset file for the 'linux' package
ALL_config="/etc/mkinitcpio.conf"
ALL_kver="/boot/efi/vmlinuz-linux"
PRESETS=('default' 'fallback')
#default_config="/etc/mkinitcpio.conf"
default_image="/boot/efi/initramfs-linux.img"
#default_options="-S autodetect"
#fallback_config="/etc/mkinitcpio.conf"
fallback_image="/boot/initramfs-linux-fallback.img"
#fallback_options="-S autodetect"

Wonder if you try the LTS version you have the same results.

This happens when a new kernel version is available so the new version gets copied in /lib/modules but something somewhere still points to the older version.

Oh, is that after reboot !

Wonder why it does so.

If I do a reboot after that error I end up with a broken system, did it twice, but if I run that second command manually it works.

Oh, this sux.

Does it do the same with the LTS kernel also !

Why are your kernel & initramfs images listed under /boot/efi/? They should be under /boot/ (as the fallback image is).

If you edited the preset then restore it to the stock configuration and reinstall the kernel package.

1 Like

Why do you mean why? Because I’m a dumb ass penguin :penguin:
I was playing with the esp partition at some point, deleted it twice and rebuilt it, I guess that’s when I did it.
I did a reinstall and it works, Thank You!

lol, it happens when we fool around with our installs.

Edit; Done it often on my end ! lol