Multiple installation fails!

I’ve tried 4 times to install ArchLabs using your installer script. I’ve tried the vanilla kernel, the zen kernel, ext4 root, btrfs root…and it has failed every time. Attached are a couple of representative screenshots. I’d love to try DK but I’ve already wasted 2 hours of my morning and no Linux distribution is worth that! You need to fix your installer! Apparently, I can only add 1 embedded object, so just one screenshot instead of three, which is a pity as each failed installation had a different error message.

Sorry for the issues but there is no need to get snarky about it. Both dk and the AL installer are developed by one person - me, as if I don’t have a job or a life, I should just spend all my time testing and working on my own hobby projects (for free!!) so you can have a pleasant experience. So sorry.

This will be looked into once I get some free time, in the meantime if you just want to try dk then install it elsewhere, it’s not reliant on AL.



First of all, welcome to AL.

Like @natemaia said in his post, “there is no need to get snarky”. No software is perfect/bug free, so is AL installer. This project is intended to help users to get Arch installed more easily than the traditional Arch way. @natemaia has done a great job writing and maintaining the software. While the installer can get the job done 99% of the time, there are still some less commonly seen configurations/layouts to remain te be the edge cases. However, from the experience, both @natemaia himself and the entire AL community are willing to help and enhance improve the software. If you could provide a little more details about your installation, for example, your disk layouts, your plan to install AL along with other OS(es) on your machine, debug steps you have done to understand where the problem might be, etc. It would be a great help.

1 Like

Hi there, AL is pure Arch under the hood and as it is written on the main web site:

ArchLabs Linux is an Arch Linux based distribution, influenced and inspired by the look and feel of BunsenLabs with the intermediate to advanced user in mind.

So please give us more details (screenshots are not all), how did you prepare your drive(s):

  • Before launching the installer?
  • Did you used the recommended layout?
  • What types of drives: nvme, ssd, hdd?
  • What part of the installation process did you missunderstood?
  • Do you have any experience on Arch or other derivatives?
  • etc…

I hope you will manage ok on your fith try.

FWIW dk installs and works well, in my experience, on Arch, manjaro, Debian, Lilidog & Devuan.

I haven’t done a test install since the recent pacman migration so I suspect that’s where the problem is. Updating the pacman.conf on the iso and refreshing the mirrors before installing should do the trick but I’m not 100%

1 Like

I don’t mean to be snarky, and I appreciate how hard it is to do this as a hobby, but therein lies the problem with 99.99% of all Linux distributions; they are one-man shows possibly with a small hand full of hobbyist contributors. Unless I go to Fedora, Rocky, Mint etc who have proprietary commercial products as foundations to work from or who have hundreds of staffers there just isn’t the robustness in distributions like Archlabs, Archcraft, Void, MX, etc to use them as my full-time work machines, even though I’d like to. That’s why my daily driver is a mac despite all its shortcomings. I’m using an MSI Godlike Z490 with an Intel core I9 10900K CPU, AMD Radeon RX 6900 XT GPU, 64GB of G.SKILL DDR4 RAM, 5x Samsung SSD 980 Pro 1TB nvme drives. I used the recommended disk partition scheme, i.e. vfat boot, ext4 root, no swap. I didn’t misunderstand any part of the installation. I’ve been using Linux including Arch variants for 4 years.

1 Like

Another screenshot

One more screenshot

Shouldn’t be the case here. More likely related to the disk layouts. The new change in pacman.conf is to move [community] into [extra]. The community repos stay active (empty contents). So even the old config will still work until they demolish the community repos sometime in the future.

1 Like

I’ve been running the same AL/Arch install for over 7 years and 2 hardware upgrades with little to no issues that weren’t my own. I can call it a work machine because I rely on it heavily to produce and fix things like dk/al/etc.

This gets into a strange discussion as to why you are trying to install these distros even though you have this predisposition/opinion.

There are guides (even on this forum by me) for doing manual installs, all of our configs and tweaks are readily available and we don’t have any “special sauce” in AL. If you’re comfortable with arch and it’s install process then you can copy a few configs and BLAMO you’re running “AL”.

I’m not saying the install failures are your problem or that I intend on ignoring it but there are other avenues if a touch more involved.

I thought so, did the upgrade on my machine without changing the conf and all worked fine. Thanks for the heads up.

@vbull you could always use my hatchery Linux ISOs too if you want a minimal dk rig and aren’t married to arch. They have dk and are based on Debian stable or testing. You can take your pick.

1 Like

The potential for @vbull 's frustration is possible to understand. I’ve tried installing AL 5-10 times in the past and have encountered similar errors. My own success rate is roughtly 50%, which is the reason why I don’t run AL on my machines.

That said, @natemaia makes a valid point about small, personal projects & predispositions.

At the end of the day, kudos to @vbull for giving it the 'ole Yankee try, @natemaia for the option & @cog for an alternative happy place suggestion.


I was just trying to give him a bandaid. Hatchery is really just my desktop. Im glad some like it but it is what it is.

1 Like

Much appreciated @cog. It takes alot of work & providing others with an option is awesome!