Mpv doesn't go fullscreen


#1

Since the last update I have made 2 days ago (in my tty before startx) something has change with mpv.
When I press f mpv won’t scale the screen and will have this space at top, of the size of the bar (but bar has disappeared so…) and also a thin border at bottom and sides. Also this is also the size of the gaps between windows.

I have tried to mess with these options:

In .config/polybar/config
#override-redirect = true
wm-restack = i3

In .config/mpv/mpv.conf
border=no
x11-bypass-compositor=no

But no difference

So I was thinking, is this possible that mpv has chosen to simulate a titlebar ? So it would explain why there are also transparent borders, like if there was some windows decoration activated in fs.

Also, when non fullscreen and playing with window modes:

So the problem doesn’t seem to coming from polybar but is really a pure i3 related thing. I have a…gap on the top of mpv (huuummmmmm)
I haven’t found a fix when searching on the internets, for now I don’t mind to watch my videos in tiled mode.
This is…exotic hehe.

Edit: compton compositing seems to be at the root of the problem, when i disable compton mpv go fullscreen, but I loose everything (transparency, effects) :smile: , I search…


#2

It is possible to instruct compton to “ignore” certain applications, check the configuration file for examples of this (I think).


#3

Thx I have added mpv in the shadow and focus exclude options

shadow-exclude = [
“name *?= ‘Notification’”,
“class_g *?= ‘mpv’”,
“_NET_WM_STATE@:32a *= ‘_NET_WM_STATE_HIDDEN’”,
“_GTK_FRAME_EXTENTS@:c”
];

focus-exclude = [
“class_g *?= ‘mpv’”,
“_NET_WM_STATE@:32a *= ‘_NET_WM_STATE_HIDDEN’”,
“name *?= ‘Authy’”
];

This has not solved the problem but at least now mpv wont be transparent if not focused, that’s a bonus.


#4

Try removing these, they hide overlapping windows with transparency when using i3’s tabbed mode.


#5

I have tried that too, no difference.
mpv is the only window who reacts like that, firefox works with f11, and so do the terminals, and they are normally tabbed.


#6

Let me do an i3 install tonight and see if I can find what is the culprit.


#7

You really do an install ? Oo
I use smplayer for now, but I keep searching, thank you.


#8

Yea sorry I just got busy with other things and wasn’t able to test it out.

Tonight I did it and I can’t recreate the issue, setting mpv to fullscreen properly takes the whole screen.

Perhaps try using our default compton config since we are fairly sure thats where the issue is from.

https://bitbucket.org/archlabslinux/skel/raw/a8da0480b3fbdc42eba39ee79030f6ac5ebafaa3/base/.config/compton.conf


#9

The default config has a lot of tearing for me (old thinkpad), I have discovered that this is not a gap in top of mpv in fact, it’s a part of the windows, normally there is a piece of the video in here but it’s totally transparent for some reasons.
I don’t feel comfortable with smplayer but I’ll stick on it, too lazy to reinstall all the system just for mpv and apparently I’m the only one in the world with that problem since I can’t find anything related on internet.
Do you think it’s possible to go on Sway from i3 without pain ? (So basically weston would replace compton, i think…)


#10

Yea it shouldn’t be too bad, depends how much you use xorg specifics


#11

Can you post your configs for compton and i3 as well as what files are in /etc/X11/xorg.conf.d/


#12

Hi, in my xorg.conf.d/
00-keyboard.conf 20-intel.conf 40-touchpad.conf

In 20-intel.conf:
Section “Device”
Identifier “Intel Graphics”
Driver “intel”
Option “AccelMethod” “sna”
Option “TearFree” “true”
Option “DRI” “3”
EndSection

Here the pastebin of i3 and compton.conf: https://pastebin.com/WHC6T1tq

I have seen somewhere that it’s possible to add the line “n:w:mpv” in compton.conf, and compton should totally ignore mpv, but without success, I don’t know where to put this line or maybe there is a syntax error in it.


#13

Try

pkill compton && compton -b --config /dev/null & 

Still have the same results?


#14

1/this method:

  • It works
  • tearing appears in firefox (and also mpv)
  • transparency is gone

2/retrying old method using paranoid:

  • mpv bugged again
  • tearing is fixed
  • transparency is back

Edit:
YES I HAVE FOUND !
Finally
Frame Opacity modified, 0 to 10.

It works now, thank you (a lot) for your time.


#15

Glad you were able to find what the cause was and got it fixed :smiley: