Move archlabs installation from one disk to another?

with great help from you guys I got my old ASUS lappy working so well with Win 10 on the original disk and Archlabs on a separate disk in a caddy in the DVD bay:

1TB Internal Disk (sda)
sda1: Boot
sda2: MS reserved
sda3: Windows: 300 GiB (205 GiB)
sda4: Windows Recovery
sda5: ArchLabs Swap: 10 GiB
sda6: Documents: 620 GiB (330 GiB)

1TB Disk in DVD caddy (sdb)
sdb1: LinuxBoot
sdb2: ArchLabs : 100 GiB (27 GiB)
sdb3: Work : 530 GiB (340 GiB)
sdb4: LapTopMusic : 300 GiB (265 GiB)

I now have a new lappy and dont need the data in the partitions sda6, sdb3 nor sdb4

So my plan is to move the Linux installation from sdb to sda and then I can use the disk in the caddy (sdb) for another computer.

Could anyone please tell me how to move AL to the other disk (hopefully move rather than reinstall!)

Could it possibly be as simple as just moving it and then updating GRUB?


I have done similar things under debian with gparted successfully several times. Since I don’t have UEFI, I can’t contribute anything specific to this.

I would suggest you need a live cd with the latest gparted. Then

  • delete sda6
  • copy sdb2 into the deleted area of sda (make sure to keep the size of 100GB).
    gparted works very reliably in this regard and has never disappointed me, also, because you can simulate everything first.

Then I would chroot from live-cd into the ‘new partition’ and reinstall grub.

First you should definitely check the different sizes of /boot/efi (sda1 + sdb1) and clean out if necessary (sda1).

Edit: Sorry, I forgot, also check the fstab (!)


Thanks @unklar :+1:

That’s what I use, Gparted, love it

I will find out how to chroot and reinstall grub

I think sda1 is big enough since it has 570 MiB free and sdb1 only has 128 MiB in it?

I will check fstab, as I made changes there

Thanks again!

1 Like

Since debian’s chroot is quite simple, I assume it is the same for arch.

I used arch-chroot in 2015 if I remember correctly.

So that might be a bit antiquated. I’m sure you’ll find the solution or an expert here can help you. :wink:


Now I know what to look for, thanks to you, I am sure I can work it out
If I can’t I’ll ask again :rofl:

ArchWiki chroot


Good Morning!
Thanks @unklar @PackRat
Due to your pointers I think I am well on my way to getting this done (if it will work is another matter :rofl:)

Using my ArchLabs live USB, after installing gparted onto it I have successfully deleted sda6 ‘Documents’ and moved sdb2 ‘ArchLabs’ and sdb3 ‘Work’ partitions to new partitions sda6 and sda7, respectively. sda3 AL is still 100 GiB.

I have also successfully chrooted (is that a word?) from the AL live USB into AL on sda3

I have successfully edited /etc/fstab so that the UUID’s and sda#'s tie up with the new partitions

Now I am reinstalling GRUB by following this guide

I am now confused as to where to mount my UEFI boot partition sda1

The fstab on the ArchLabs sda6 has a mount point of /boot for sda1 (as shown in the gparted screenshots in my first post above when it was in its previous position on sdb)

This is also the case (/boot) on the AL installed on my new lappy

However, when in my new lappy actually running AL (which I recently newly installed alongside the Win 11 it came with), I get the below:

leigh@T16-AL ~ % ls /boot
'System Volume Information'/

leigh@T16-AL ~ % ls /boot/EFI

leigh@T16-AL ~ % ls /boot/EFI/BOOT

leigh@T16-AL ~ % ls /boot/BOOT    
leigh@T16-AL ~ % ls /boot/EFI/archlabs 

leigh@T16-AL ~ % ls /boot/EFI/Boot    

So, I am only 92.5% sure that I should mount sda1 at /boot (and not /boot/efi or /boot/EFI) during the reinstall GRUB process, since I can see a /boot/EFI etc etc in the above (however, I think that all the /EFI etc is from the Win 11 side?).

Could anyone, please,

(a) confirm I am on the right track?

(b) confirm that I should mount UEFI at /boot from my Archlabs installation whilst reinstalling GRUB?

EDIT: This post moves me up to 97.5% sure it’s /boot :rofl:

OK, I took the empirical root (Freudian typo there LOL - route) - suck it and see

I used /boot and,

A first boot into AL (I think Linux) gave me an ‘initramfs.something not found’ followed by kernel panic

Then I booted successfully into Win 10

Then I tried AL Linux again and it worked!

So I ran ‘update-grub’ (felt like a good thing to do)

Then rebooted into AL Linux-LTS sucessfully

Looks like its all good to go

Now I can take out the DVD caddy and try to put it in the 410s, and use the 1TB SSD sdb from the ASUS as my external ‘work to and from home’ disk

Boots in a flash too - still not sure why its so, so much faster than my new Thinkpad racing machine (where are my meds…?)

Thanks @unklar @PackRat !!!

I learned something new!

I can now sew on my Scouting ‘chroot’ badge (although I had no idea what I was doing)

1 Like

It turns out that I can only boot into LTS
and further inspection of fstab tells me that its doing that from the linuxboot and AL partitions that are still on sdb.

booting into Linux linux gets stuck at a start job for /dev/disk/by-uuid/5A5B\x2f etc

I can distinclty remember a 5A5B in the fstab as I was working from the live USB into the AL partition, but now there is no such entry
But 5A5B is the Efi sda1 partition

I think Having left the original AL and Work partitions on sdb after copying them to sda could be a problem? both copies have the same UUID

OK, now I am stuck

I deleted all partitions from sdb (so this includes the old sdb linux boot and old sdb AL partitions)
Nuclear Option taken

Then I double-checked my fstab and there was a mistake in the UUID it couldnt start before (US keyboard is ‘/’ where ‘-’ is on PT keyboard and I didnt notice that one - I now use sudo setxkbmap pt in live USB terminal 1st thing!)

My fstab has three entries:

  1. AL OS partition correct UUID, sda6, mounted at /, ext 4,
  2. Boot partition correct UUID, sda1, mounted at /boot, vfat
  3. Linux Swap partition correct UUID, sda5, no mount point, swap

EDIT: fstab below:

# /dev/sda6
UUID=e39d8e26-bfbc-4b98-82aa-b9f517273ad2	/         	ext4      	rw,relatime	0 1

# /dev/sda1
UUID=5A5B-B396      	/boot     	vfat      	rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro	0 2

# /dev/sda5
UUID=d06f9174-8e6f-46d0-a610-295cc5bd817a	none      	swap      	defaults  	0 0

#LABEL=Documents /run/media/leigh/Documents ntfs3 nosuid,nodev,nofail,x-gvfs-show,uid=1000,gid=984 0 0
#LABEL=Work /run/media/leigh/Work ntfs3 nosuid,nodev,nofail,x-gvfs-show,uid=1000,gid=984 0 0
#LABEL=LaptopMusic /run/media/leigh/LaptopMusic ntfs3 nosuid,nodev,nofail,x-gvfs-show,uid=1000,gid=984 0 0

Then, using AL live USB:

I mounted the sda6 AL OS partition:

mount /dev/sda6 /mnt

I mounted the sda1 FAT32 boot partition at /boot (also has Win boot manager on it):

mount /dev/sda1 /mnt/boot

Chroot into AL OS partition:

arch-chroot /mnt

Reinstall GRUB:

pacman -S grub efibootmgr os-prober

They were all up to date but I reinstalled to be safe

grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub

NB - /boot not /boot/efi
Installation Finished. No errors reported

grub-mkconfig -o /boot/grub/grub.cfg

Only adds boot menu entry for EUFI settings
cant find grub drive for sdc but that i because sdc is the USB live session

If I reboot, I get just grub with UEFI settings, so os-prober isnt finding neither my Win partition nor my AL OS partition

I checked in /etc/default/grub and the line below is present and uncommented:


Windows still boots if I put Windows boot manager 1st in the BIOS boot order

Any ideas?


I assume you’re leaving Windows as is on both laptops.

Back up your data

Get the laptops set up the way you want; DVD caddy moved etc …

Boot live session AL and do a clean partitioning and installation. The system looks pretty well buggered up right now. Do a clean install and everything will be set the way you want.


thanks @PackRat
Yes windows installations are fine on both laptops
I have multiple backups of my data - I’m not worried about that
the T16 Thinkpad is now the ‘Master’ Laptop and all is great on that one

I was actually starting to think that I could have done a clean install of AL on the old Lappy sda by now, instead of trying to move it from sdb to sda :rofl:

I shall do that, after taking the caddy out (that’s destined for the T410s)

Was fun to try tho

Thanks again


Well, problem solved

After taking out the caddy and putting back the DVD drive the dodgy ribbon cable to the power button didnt work, so I took it all apart again and played with the cable, it worked. screwed it all together and it didnt work, then again, and again, I reckon 10 times and finally it just wouldnt boot at all.

it could be said that I fixed it till it broke, but the wheels were coming off the wagon, keyboard, cables, USB ports, microphone, camera etc

I think its time to say goodbye

RIP ASUS X550LB - you served me well

… where’s that old T410s?

Welcome brother, you’re in good company.


1 Like

The thing is, what do I do with these old laptops that dont work or are so slow to make them useless?

I have a growing pile, and dont seem to be able to let them go …

Recycle or donate them.

There is a user on the BunsenLabs forum (username trilobite, I think) that takes donations of older, sometimes broken, laptops. He (his group) fixes them up best they can and installs BL on them. Donates them to low income and people that are basically shut in, but have access to internet. He might be able to hook you up with a similar group in your area.


Good idea
I’ll try these

ribbon cable in the post
I just cant let go …

Good. I highly approve.


It’s Alive!!!

A new 6 pin, 0.5 mm pitch ribbon power button cable and she fired up with no hesitations!!!
(except for the first try when I put the damn thing in upside down :joy:)

I got a 20 cm one so that it wasnt so strained as the original 15 cm one when lifting the keyboard (or maybe I just couldnt be @rsed to open the lappy up again to measure it, and guessed the length wrong …)

Now I only have the 1TB SSD with Windows on it in the main internal disk socket, but I can now reinstall ArchLabs into the spare partition and I have a perfectly good ASUS back, WooHoo!

Mind you, that old T410s plus caddy SSD and 4GB RAM actually seems snappier than this ASUS X550LB with SSD and 12GB RAM now. I must try to get another 4GB RAM for the T410s to bring it up to the max 8GB.

And, of course, having now been on the T16 i7, I couldnt go back to the ASUS again.

1 Like