Mount failed during installation

I tried to install ArchLabs in a VM and got an Error during the mounting process. Regardless if I skip formatting or trying to mount a second partition I get:

Confirm the following mount options:
Error:,Expected,3,arguments,,found,extra,2. Use,--help,to,list,options.

If you select Yes, I get “Mount failed.” and if I select No, the dialog shows right up again.

For my first installation I used the automatic partitioning which adds a 512MB partition for /boot, which I cannot mount.

Any advices?

Hmm, lemme do a bit of testing to see if I can reproduce and fix

I can’t reproduce this issue, possibly something else at play not really sure

Can you try this iso and let me know if your still getting the same issue

https://drive.google.com/open?id=1REjy-wtrLPp68LimpMEuts4CVneAModO

Also, more info wouldn’t hurt

  • what is the partition layout, default auto partition setup?
  • what filesystem type did you choose for /boot
  • what mount options did you choose for the above filesystem

I haven’t used VM for awhile, but maybe increasing your memory size may help. If I remember correctly when I had a problem mounting for Ubuntu, I had to have my memory at 1024.

  • partition layout is the default auto partition setup:
    512 MB for /boot
    the rest for /
  • filesystems:
    / - ext4, noatime (can be mounted)
    /boot - ext2 (no selection provided for mount options)
  • noatime for / and there was no selection provided for /boot

I set 3GB of RAM vor the VM and 1 CPU.

I made some screenshots of the process: https://imgur.com/a/aupMs
The screenshots are made with the 2018.03 iso

May I ask what OS you are running your VM on? Like Linux or Windows…
And if Linux, which distro.

My Host ist running Arch Linux, all up to date.
I even tried installing ArchLabs on one of my Laptops and run acros more issues:

  • You can’t mount partitions with the installer without formating them.
  • After he installation the installer isn’t able to run mkinitcpio correctly and removes all installed files right after failing…

I think thats not supposed to happen?

Edit: Is there an issue tracker? Found more bugs in the installer according LUKS :smiley:
Edit2: The installer keeps deleting all of the installed stuff :disappointed_relieved: … It’s really hard to use ArchLabs, if you’re not really able to get it installed. I tried to finish the missing steps manually, but the installer just wiped all data on the root partition -> all of the work vanished without any warning. I don’t get, why you’re deleting all stuff, just because one step failed. It wasn’t even my fault, it’s reproducible that mkinitcpio fails every time I try to finish that step.

Okay, I just did a test on my machine .These are the settings I used for setting my VM machine:

            Name: ArchLabs
            Type: Linux
            Version: Other Linux (64-bit)

            * Storage on Physical Hard Disk: Dynamically allocated
            * File allocacation and size: ArchLabs 63.00 GB
                Advanced Settings
            * Shared clipboard:Bidirectional
            * Drag'n Drop: Bidirectional
                System
            * uncheck floppy
            * Processors: 2
            * click on extended features
                Storage
            * under controller IDE choose Virtual CD

I would try doing these settings on your machine and see if they make any differce. Then we will go from there.

Thanks for the extra info, this makes it much easier to find

The problem currently is regarding choosing ext2 (or any other filesystem without mount options) as the filesystem, I’ve found the issue and its an easy fix.

As a work around for now use ext4 as /boot

Wrong forum

2 Likes

I will have an iso out that resolve the issue however, if you would prefer it not wipe failed installs edit the following in /archlabs-installer/archlabs-installer

# Search and replace this (around line 115-120)
rm -rf ${MNT:?}/* ; main_menu

# With this
main_menu

It is within check_for_error()
You can see here Github Code Link

Again huuge thank you for the patience and will post back with a new iso

EDIT

After a quick thought I decided at least providing a choice to attempt a fix manually so this is what I’ve got

check_for_error() {
    if [[ $? -eq 1 ]] && grep -wqi "error" "$ERR"; then
        msg=$(cat "$ERR")
        dialog --backtitle "$BT" --title " $_ErrTitle " --msgbox "$msg" 0 0
        msg="An Error was encountered\n\nIt is recommended to wipe the installation and start over\n\n"
        msg="${msg}However you may select 'No' to attempt a fix yourself"
        if dialog --backtitle "$BT" --title " $_ErrTitle " --yesno "$msg" 0 0; then
            rm -rf ${MNT:?}/* ; main_menu
        else
            main_menu
        fi
    fi
}

Cheers

1 Like

LOL Indeed.

1 Like

Indeed you can, just during filesystem selection choose “Skip / None”

This is also mentioned earlier on that partitions can be mounted in this way without formatting them

Okay, I got the message. Red faced. I also edited my response. :flushed: I am an engineer, when you do any experiments, you note what platform, IDE, and machine that you used so individuals don’t misconstrue your intent. This is what I was taught and to do in the field. It just bled into this forum.

1 Like

@quizzi If you’re up for it, an iso with most of the issues resolved is now available Here

@sevenday4 Don’t worry mate, no harm done :slight_smile:
It just helps a lot solving issues if it is indeed our distro :stuck_out_tongue:

1 Like

From the first post @quizzi wrote:

I tried to install ArchLabs in a VM and got an Error during the mounting process. Regardless if I skip formatting or trying to mount a second partition I get:

Well I did use AL. In Oracle’s VM. But wanted to make sure it was another platform to try and duplicate @quizzi situation. I couldn’t get it to fail like he is experiencing. So I thought I would share the settings that I used to maybe help him.

As side note @Dobbie03 and I discussed the issue, and now I understand.

1 Like

Ahh, I think this may have been a misunderstanding on my part

Apologies

2 Likes

No problem, this was a complicated issue to deal with. Still not sure what is causing his issue. Anyway, that other OS is about to come off my system. Finally got AF to behave out of the box on my second hdd. Finally!

1 Like

This iso fixes most of the mounting issues! Is it intended, that you can’t provide mount options if you don’t format the partition?

Accodring LUKS:
With the installer, you “can” open a normal partition and receive a succes message, but indeed nothing happens xD
You have to provide the password twice to open a LUKS container.

Do you think a german translation might be useful? If I have a bit more free time, I might be able to provide one.

1 Like