Mod key used to run rofi?

So, am I mistaken in that I’m sure yesterday before the update that pressing Mod4(windows) key on i3 brought up the rofi menu? Even if I am, how do I put it back as a binding?

Have tried:
bindsym Mod, $Mod and Mod4

but nothing works. I can use the Mod1+F1 key combo but meh, so I’m using:
bindsym $Mod+d
which isn’t ideal… pressing the Mod4 key on it’s own to bring up rofi is just efficient.

Off topic, where can I get an Arch/labs key sticker :wink:

Install ksuperkey

Yes, but am I wrong in remembering that before yesterday just pressing Mod4 worked?

Before the update I had that settled too, but I got ksuperkey removed somehow, installing it again solved it.

Ok will try and report back. Would like to know how it got removed though.

So, this is the current binding for the new AL version:
bindsym Mod1+F1 exec --no-startup-id rofi_run -r

I looked back over the last few of mine and they are the same. Now it is possible that at some point in the past you may have setup a diff binding for that?

Sometimes it happens when Linux &/or Arch updates , it might remove some dependencies ( always be aware of those when updating or upgrading) or might be some bugs going on, it s why I wait in order to update my systems sometimes.

ksuperkey installed, rebooted, now works as before. Thank you all <3

Glad that you got it sorted out.

Ah yes. ksuperkey - within a previous i3 config this was there:

#pressing super key alone simulates pressing Alt-F1
exec --no-startup-id ksuperkey -e ‘Super_L=Alt_L|F1’
exec --no-startup-id ksuperkey -e ‘Super_R=Alt_L|F1’

Just as an addendum, I changed back to previous setting:

bindsym $Mod exec --no-startup-id rofr.sh -r

Thing I love about linux: always something new to learn/realise.
Thing I dislike… see above :stuck_out_tongue_closed_eyes:

1 Like