Major Issue with Firefox addons

firefox
#1

Perhaps this should go in announcements?

Im using libfaketime to combat this stuff up by firefox and all my addons are ok for now.

https://www.archlinux.org/packages/?name=libfaketime

faketime 'last friday 5 pm' /usr/lib/firefox/firefox

2 Likes
#2

It’s fixed already

#3

I can’t live without ads blocking!!!
There’s another way to fix it:
open firefox and open about:config page, search for xpinstall and set it to false by double-clicking

xpinstall.signatures.required …false

then open about:debugging, check box ‘Enable add-on debugging’ click on ‘load temporary Add-on’ search for your app.xpi in ~/.mozilla/firefox/WHATEVER.default/extensions/staged/myapp.xpi
Reload your addon, it’s done.

1 Like
#4

Can you point me to the update saying this is fixed as of 2 am 05/05/19 (AU) AEST as it is not fixed for me yet. All my addons are still disabled. Please consider that this issue is global and affects most current stable firefox installations.

#5

Not a workable solution on my end ? Seems too convoluted and prone to error if i may add.

#6

I’m on firefox now, so far everything’s working fine

#7

673 votes and 222 comments so far on Reddit

#8

Also this

https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/

It’s not fixed for me but my addons are working, I just can’t install anything new. I personally wouldn’t do the fix that they suggested. There is a reason I disabled “studies”. I don’t want it turned back on.

Wait until a proper fix is out.

EDIT: I checked my settings, and for some reason allowing Firefox to send diagnostics and the studies option was turned back on! FF must enable these again after an update? I don’t know but I have lost faith with Mozilla after their past stuff which I have ignored but this pisses me off. Why have the option to disable these when all that happens is that they are enabled? It’s sneaky beyond words. I’m removing all FF related shit from my PC and phones. Qutebrowser is once again my default.

Anyway, I disabled these and addons work again.

#9

My stuff just started working around the time of my previous reply.

#10

Mine was working too … it was the fact diagnosis etc had been re-enabled without myself doing that which pissed me off.

Qutebrowser is a more than adequate replacement anyway. I had been using it for weeks solid anyway until a couple of days ago.

#11

Been having this going on as well, love when shit happens like that.

#12

I wont be doing any workarounds until this is fully fixed, using libfaketime just for firefox works for now.I use libre fox which disables studies and id like to keep it that way. As of right now it is still not corrected for my firefox. Until there is a complete fix not a workaround ill stick to using palemoon again.

#13

Yeah, the Debian package disables those options by default, which is nice.

Arch always uses the upstream defaults though.

Posted from Chromium :grin:

#14

Hmm looks like libfaketime is not a valid workaround either. The below keeps popping up. Definetly back to palemoon now, fuck firefox.


An error occurred during a connection to www.archlinux.org. The OCSP response is not yet valid (contains a date in the future). Error code: SEC_ERROR_OCSP_FUTURE_RESPONSE ```
#15

FWIW, Mozilla have asked people not to try the various workarounds being posted on the interweb because they will interfere with their fix.

But yeah, fuck 'em…

#16

Well retrying Qutebrowser again, will be a learning curve I guess ! lol

#17

Yeah i saw that they did not recommend doing any workarounds and i agree, they need to fix what they broke, not put a bandaid over it. Also as has been mentioned elsewhere, surely they would have had email alerts regarding impending certificates needing to be updated days, weeks beforehand, something isnt right imo.

#18

There’s the fix - switch browsers. I started using Vivaldi last night. Probably stuck with Chrom[ium] on my phone :crying_cat_face:

#19

Im using icecat on my phone, not had any issues with addons there yet, might be handled differently not sure.

#20

Which is something I quite like. Though making people aware of what is turned on by default should be mandatory from the developers. You should get a pop up on first install of FF saying that Diagnostics/Studies is on by default and be given the option to disable it.

I tend to agree here :smiley:

A learning curve well worth trying :smiley:

I normally don’t worry but something about this really ticked me off, I suppose the bullshit Mozilla have been pulling for the last few years just built up and this was the last straw.

One option was to set the clock back. Remember when Manjaro suggested this “fix” when nobody could access their website. The hoo-harr the interwebs brought down on them was crushing, seemingly no one seems to care that Mozilla suggested this.

Yuk :wink: