MacBookPro 8,1 report

Hello fellow Archlabbers!
I have been running Archlabs on my 2012 MBP for about 3 months now! I have everything I need working now! I have compiled my own SheepShaver on Archlabs to run Mac OS 8 and 9 and it just works. Even wireless scanning works.
Itś running smooth here. Thank you Guys for this wonderful system!!



Awesome news. Did you have to do anything tricky to get ArchLabs running on the Mac Book?

Not really! Using the ordinary kernel. Had to disable csrutil on the mac. Ananicy, mbp-fan and a few other small things! Archlabs is very easy to work with so far!

1 Like

Bloody great to hear.


Completely agree. Working on Macbook Pro 11,5 with discreet gpu and hidpi screen. Everything working smoothly. Just added some soft for power management and most of the things working out of the box. Finally found Arch with easy installer. Was a bit pita to do it manually every time.
Good job :+1:

1 Like


Which steps and packages do you have installed extra to get discreet gpu and hidpi screen working on your Mac?


Using as reference, but main change is in .Xresources:
xft.dpi: 192

Regarding the GPU - needs to use refind and gpu-switch to switch between integrated and discreet gpus.

This page is also useful.

Ok, thanks!
I did not know gpu-switch, will check out that it will do the trick.
And what about Bumblebee, which one works the best?

You should use either grub-git or refind to boot with needed grub parameter apple_set_os.,x#Getting_the_integrated_intel_card_to_work_on_11.2C3

Then you can run sudo gpu-switch -i and reboot to use integrated GPU. The issue for me was that external display working only with discreet GPU.

Never used nvidia gpus on my laptops, can’t help you about the Bumblebee.

I have installed on MBP 8,1 (late 2011) and it has intel gpu and no retina so it is very easy!

@dimaom: MacBookPro11,2 has only an Intel Iris Pro 5200 GPU.
Why you use gpu-switch then?
@womp: Yes, i have a MacBookPro9,1 (2012) with rEFInd triple boot Antergos, Archlabs and MacOS. But never got the two gpu’s working on the Arch distro’s, only the Intel one.

I am looking out to switch to a less older MBP (2014-2015).
That’s why i want to find out more.

I have different model 11.5 with discreet radeon chip.

Ok, then it has an Intel and AMD Radeon R9 M370X. Strange i have read on many websites that it’s really difficult to get Arch running properly with AMD Radeon R9?
I have let go an MBP11,5 for a good price because of that reason.

I don’t recognize that I have written that! Have never owned a 9,1 mbp! Very strange!
I must also tell you that my “old friend” macbookpro 8,1 (late 2011) died last night! There are too many repairs. It’s better to save up for a more linux-friendly laptop instead!
In the meantime I use a 64GB usb-stick with my work computer. It’s a late 2014 mbp 13 retina. Most things work fine now! I even got sceen resolution stick between reboots now!


It was a reply on you saying “… so it is very easy!”. So, i have already managed to get all working except the two gpu’s. Don’t want/need more computers, but need MacOS for Max software. Because i need some software that’s not existing on Linux.
Sorry for crossposting, but was thinking that this could be a nice MacBookPro thread.

In my experience it’s better to use linux on macbooks with integrated gpu only. Don’t want to mess with discreet gpus anymore. Not a gamer myself.
Got a new Thinkpad X1 as working computer last week. Don’t want to go with macbooks any further - they lack performance, good keyboard, ports, etc. And I was using macs only during last 12 years. With macos and linux. But I can live without mac specific software nowdays, luckily.

Hi! I have more on MBP8,1 (2011-2012 not 100% sure)

My MBP 8,1 (2011-2012) has been running rather well so far but 4 days ago it started to wake up a few seconds after suspend. (very annoying!) Temp got very high in just 10-15 minutes!
I searched for solutions to this and found hundreds with the same problem. Many solutions but I just few that I found worth trying (and that would work on this model).
Best result was suspend for 2 hours and wake up. Not good enough.
By chance I found linux-macbook kernel in AUR. I was desperate enough to try. 3 hours later I tried it and enabled macbook.wakeup.service and suspend seems to work now!

The downside is that it will probably take hours to update the kernel but otherwise kudos to the macbook-kernel-creator.


I had issues with the 340-xx-dkms Nvidia legacy driver on my 9.1 iMac on both Arch and Debian, one crash that was fatal. I just never bothered to figure it out, I don’t want to config or hack stuff to get something that works in Mac to work in Linux. In fact, when I used to dual or tri boot on it with the old rEFIt, the distros that worked best were Mint and Ubuntu Studio, I even had the Nvdia GUI config app working without failure.

1 Like

I have a macbook pro running AL. Never had this issue. Can you post,

$lspci -v


$sudo journalctl -f -u systemd-logind