Logitech G29 with Steam [SOLVED]


#1

Hi guys. Probably just some little thing, but i can’t get my Logitech G29 to work in Euro Truck Simulator 2.

ArchLabs (dmesg and lsusb) and Steam sees the wheel but i can’t control the game with it, only with keyboard. I’ve read online that it should be plug&play device in Linux, but… My head is jammed right now. :stuck_out_tongue:

Should i put something in here:


#2

Can you bind it in-game?


#3

Nevermind, i sorted it out. Deleted my game (trucking) profiles in ETS2 i’ve created and made a new one, now it works.


#4

Spoke too soon, it doesn’t work after all. Tried it in my Windows 10 laptop and got it to work after i installed some Logitech software from their site.

I don’t know what’s the problem… Linux sees the wheel, Steam sees it too, but when i try to configure the buttons on the wheel and the pedals in ETS2 profile, it doesn’t recognise the device. It was the same in the Windows also, but the Logitech software did the trick i guess.

I tried ltwheelconf in terminal, but didn’t quite understand the output. It looked ok though. :stuck_out_tongue:

This isn’t ArchLabs issue by any means, and maybe belongs to hardware section anyway.


#5

Bit of a hack, but you can redefine inputs to emulate something else (like multiple keys being pressed), has to be done via an xorg config. Then you can bind those keys in game and should be golden. Just make sure to only do it for the proper device by using

Identifier "my_unique_label"
MatchProduct "my_product_name"

https://wiki.archlinux.org/index.php/Libinput


Seems this is just a thing with the g29 (and possibly other wheels)

Have you done due diligence and searched this yet?
I googled Arch linux logitech g29 and got:

(yes it’s Ubuntu, but you can easily translate the steps across for Arch)
and

The reddit thread claims:

Make sure you have the wheel set in PS3-Mode (the little switch on the middle of the wheel) Works fine for me in ETS2 and ATS but no Force Feedback.


Sorry I can’t offer better help, I’ve just never used or configured one of these input devices so most is lost on me.


#6

Thanks, natemaia. That Steam community link looks promising, it covers ltwheelconf which i think is necessary thing to do. I found the Reddit link yesterday, but it didn’t help. In fact the switch in the wheel must be in PS4 -mode (thread claims PS-3), otherwise it doesn’t work at all.

---->LTWheelConf… :stuck_out_tongue: