Login and x stability

Installed dwm with no login manager sometime last year. Was good but after a couple of days it had some x IO error when i did a startx and refused to get into the GUI. Went back to i3 and lightdm.
2-3 months ago I installed DWM with no login manager again. Worked just fine till 3-4 days ago. And then shit got weird. Every time i opened a file through ranger with subl it would launch but if i used ranger to launch another file with subl the x thing would crash and dump me back to the tty from where i would startx agian and reopoen all my apps. Or if i would copy a file using thunar and the folder contains same file confirmation dialog would come up it would crash too. With qute if i launched 2 instances without already having one open and they launched together. So I nuked it again figuring that hopefully its a startx issue and maybe using a login manager would help. So installed dwm with lightdm.
First it wouldnt show up as an option. Used a tty to add the damn dwm.desktop entry to usr/share/xsessions and a bunch of other like deleting the xauthority file in my home dir and what not. It shows up in the options now but when i login it i just shows a black screen and logs me back out to lightdm. when i try to startx from a tty it says command not found.

My question is 1. If i stick to startx can i fix the x crashing issues that eventually crop up because i tried everything from changing drivers to changing the gtk theme to installling some deps etc and nothing worked.

  1. If using startx is not a good idea how the hell do i get lightdm working or should i maybe use another login manager like ly or something but ly also didnt work with dwm or i3 install and the forums told me i shouldn’t install it while installing the os but after installing lightdm and the os and then removing lightdm and installing.

Thanks. Pleaase help. Using my win part which i literally only have for coh and lol and i hate this lol. Tho opera browser isn’t bad compared to ff certainly lighter lol.

Is xorg-xinit installed ?

Was that after an update ! Sometimes it happens.

incase of dwm with startx which was working yes.
incase of dwm with lightdm in which i cant login i would assume so because i installed using the normal arch-installer and the issue is only when i select dwm. Not with i3 or awesome. it’s not availible as an option and after it after i fix that it logs out after login immediately and automatically.

I update almost daily. There were some gtk updates both before and after the problem 1st arose. can’t be sure about x updates and can’t tell now because i’ve already nuked that part trying to install dwm with lightdm.

Ah ok, we ll never know which one to point out this might help;

Please give output of journalctl ;

As @archus stated above is xorg-xinit installed as well as latest libinput!

yes. checked from the tty using pacman -q and searching in the generated file using vim or nvim or whatever editor this is.

Do you have Invidia !

Thx for the comeback, are these the latest version! Or you might have to get the versoins that were working.

haha no. Already saw myself online in forums that nvidia causes many probs but i have whatever intergrated intel video card on this.

lol, hey cool, was wondering about it.

assuming they are latest. Just isntalled the system with the al-installer and ran a baph -un too.

I doubt i’m the only one trying to install dwm with lightdm and getting this issue. Pretty sure it has something to do with dwm installing after lightdm is done atleast the bit of lightdm not detecting dwm as an option.

Oh ok thx , so it s a fresh install. Please post results;Might help, never know

inxi -G

& lghtdm.conf

Okay so typing from my phone now. Had to logout of win to run commands. Booted arch. Reached lightdm. Ctl + alt + f6 for tty. Then inxi -g. Output is command not found. Same for lghtdm.conf.

Oh, didn t know you were on a phone.

Can t help you much here, maybe someone else might help .

But the laptop I’m having trouble with is right in front of me. Anyway, probably just gonna reinstall without lightdm and hope it don’t have such issues in this install.

ah, maybe the configs weren t done as weirdly as it sounds

I just use the .Xinitrc option to start dwm etc. Are there any crazy entries in your .xinitrc that could be causing an issue?