ArchLabs Linux

Lock screen, blank out time

In plain arch my screen went black the moment I would lock the screen. That was with i3. Now I’m running ArchLabs with Openbox and it takes a very long time for my screen to go blank when I lock my screen. Where can I change the setting to be 1 or 2 seconds?

What screen locker is being used, i3lock-fancy?

I don’t think there is a way to change the time for that because it’s taking the screenshot, blurring it, and setting it as wallpaper before locking the screen. i3lock-fancy is a bash script, though maybe it can be edited?

I think the simplest route would be to switch to plain i3lock, or slock. i3lock-fancy calls i3lock to actually lock the screen so it may already be installed.

I don’t know if it’s i3lock-fancy. I’ll look into it tomorrow and check if the shell script contains some timeout option. i3lock just looked the same on Arch i3 as the lock screen I now have on AL with openbox.