Local package newer than remote

hi all,

I am usually doing normal updates with sudo pacman -Syu and everything goes well, load of packages but all good.

recently I am getting this and I am not so sure on how to fix it

warning: zathura-pdf-mupdf: local (0.3.7-1) is newer than community (0.3.6-5)
warning: zeromq: local (4.3.4-2) is newer than community (4.3.3-2)
warning: zim: local (0.74.3-1) is newer than community (0.73.5-1)
warning: zimg: local (3.0.3-1) is newer than extra (3.0.1-2)
warning: zlib: local (1:1.2.11-5) is newer than core (1:1.2.11-4)
warning: zsh-completions: local (0.33.0-1) is newer than community (0.32.0-1)
warning: zstd: local (1.5.0-1) is newer than core (1.4.9-1)
 there is nothing to do    

Do you have all those repos on your install or it just states it.

apologies in advance,
I am not too sure what you mean by that …

Perhaps, if that answers your question, here are my pacmna confs

╰──$ cat /etc/pacman.conf
#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
RootDir     = /
DBPath      = /var/lib/pacman/
CacheDir    = /var/cache/pacman/pkg/
LogFile     = /var/log/pacman.log
GPGDir      = /etc/pacman.d/gnupg/
HookDir     = /etc/pacman.d/hooks/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
UseSyslog
Color
#NoProgressBar
CheckSpace
VerbosePkgLists
ParallelDownloads = 5

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Optional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

#[multilib]
#Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs    

and mirrorlist

╰──$ cat ./mirrorlist
################################################################################
################# Arch Linux mirrorlist generated by Reflector #################
################################################################################

# With:       reflector --connection-timeout 5 -p http -l 30 -n 20 -c 'United Kingdom' --sort rate --save /etc/pacman.d/mirrorlist
# When:       2022-01-06 02:20:28 UTC
# From:       https://archlinux.org/mirrors/status/json/
# Retrieved:  2022-01-06 02:20:14 UTC
# Last Check: 2022-01-06 02:16:38 UTC

Server = http://mirrors.ukfast.co.uk/sites/archlinux.org/$repo/os/$arch
Server = http://www.mirrorservice.org/sites/ftp.archlinux.org/$repo/os/$arch
Server = http://lon.mirror.rackspace.com/archlinux/$repo/os/$arch
Server = http://mirrors.gethosted.online/archlinux/$repo/os/$arch
Server = http://mirror.netweaver.uk/archlinux/$repo/os/$arch
Server = http://mirror.cov.ukservers.com/archlinux/$repo/os/$arch
Server = http://mirrors.manchester.m247.com/arch-linux/$repo/os/$arch
Server = http://mirrors.melbourne.co.uk/archlinux/$repo/os/$arch
Server = http://mirror.bytemark.co.uk/archlinux/$repo/os/$arch
Server = http://archlinux.uk.mirror.allworldit.com/archlinux/$repo/os/$arch  

Oh ok thx for the comeback in there, looks like you have several repos in your mirrorlist, which might be the cause, but it might not help.

I would have the one closer to you or the fastest activated.

I see,
reflector does that ( see the command on the top of the mirrorlists

Even after I removed all but one in the mirrorlist still getting the same issue ( unless the UK mirror hasn’t been updated )

This seems to be a duplicate post
based on
https://bbs.archlinux.org/viewtopic.php?id=128502

I will try to update the mirrorlist and see if its solving the issue

Which is weird if it comes back to same results.

Solving my own post,

If reflector creates mirrorlists then rerun reflector or review reflector arguments to ensure mirrors are created correctly etc .

few examples are
sudo reflector --latest 20 --protocol https --sort rate --save /etc/pacman.d/mirrorlist
sudo reflector --connection-timeout 5 -p http -l 30 -n 20 -c 'United Kingdom' --sort rate --save /etc/pacman.d/mirrorlist

1 Like

Glad that it worked out, did it yourself actually ! Good job.

I would run this command only as @Head_on_a_Stick stated somewhere that I don t remember where after you runned reflector one.

pacman -Syu
1 Like