LightDM screen not displaying login screen

Been having issues with the LightDM login, not displaying possibly due to either the backlight not firing or something else. Right now in my other boot in Sparky, so I can try to find a log by getting into the boot partition or elsewhere. This has been an issues for the past few days, and I reinstalled AL in case I missed something, but now it reoccurs.

I am most likely going to to a complete reinstall of my dual boot on my Thinkpad using rEFInd, see what happens after that, and I have Sparky booting from it’s own EFI partition, and AL booting from it’s own, and it’s probably a Grub thing, but in the meantime if there are any suggestions I would appreciate it, albeit I don’t have any log or output posted, for which I apologize.

Did reinstall, same issue. I can login via tty, but startx in zsh is giving me issues, maybe I shouldn’t use zsh lulz.

Check xorg log and output of “journalctl -b” to see if you can find any clues. I am using startx from zsh to launch X, no issues.

@chroot I am able to login, haven’t done the launch x yet, and I reinstalled Sparky with no issue, so I can get into any xorg file in AL from here. I load the Zen kernel on every install, don’t know if it’s kernel related, but for the most part AL has been stable. I thought there may had been a possibility of Sparky having a part in it, but as I pointed out earlier, it was on it’s own EFI partition, and in this latest issue, Sparky wasn’t installed yet. I’ll check it out later and post the results, but thanks a lot for the help, it’s much appreciated.

Have you searched the forum. LightDM not working properly is a running issue; unfortunately, no universal fix.

What issues? You can search for zsh on the forum; usually just have to comment out a line to get everything working. Or delete the default configuration and make your own zsh environment.

^ This.

And also check the LightDM log.

@PackRat I reinstalled LightDM at arfter the TTY login, I figured it’s probably an issue with it, may try SDDM since I prefer a graphical login to xinit due to all the WN’s at hand.

zsh gives me a "change start to stat [nyael] argument((?), which doesn’t seem to work (neither does ‘launch x’). zsh to me is basically eye candy for terminal, as I like good ol bash but I like to try out the new toys.

@Head_on_a_Stick I am gonna pour into those in a bit, will post results.

[     2.364] (--) PCI:*(0@0:2:0) 8086:1916:17aa:2233 rev 7, Mem @ 0xe0000000/16777216, 0xc0000000/536870912, I/O @ 0x0000e000/64, BIOS @ 0x????????/131072
[     2.370] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[     2.370] (II) LoadModule: "glx"
[     2.376] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[     2.381] (II) Module glx: vendor="X.Org Foundation"
[     2.381] 	compiled for 1.20.10, module version = 1.0.0
[     2.381] 	ABI class: X.Org Server Extension, version 10.0
[     2.381] (==) Matched intel as autoconfigured driver 0
[     2.381] (==) Matched modesetting as autoconfigured driver 1
[     2.381] (==) Matched fbdev as autoconfigured driver 2
[     2.381] (==) Matched vesa as autoconfigured driver 3
[     2.381] (==) Assigned the driver to the xf86ConfigLayout
[     2.381] (II) LoadModule: "intel"
[     2.381] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[     2.383] (II) Module intel: vendor="X.Org Foundation"
[     2.383] 	compiled for 1.20.9, module version = 2.99.917
[     2.383] 	Module class: X.Org Video Driver
[     2.383] 	ABI class: X.Org Video Driver, version 24.1
[     2.383] (II) LoadModule: "modesetting"
[     2.383] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[     2.385] (II) Module modesetting: vendor="X.Org Foundation"
[     2.386] 	compiled for 1.20.10, module version = 1.20.10
[     2.386] 	Module class: X.Org Video Driver
[     2.386] 	ABI class: X.Org Video Driver, version 24.1
[     2.386] (II) LoadModule: "fbdev"
[     2.386] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[     2.386] (II) Module fbdev: vendor="X.Org Foundation"
[     2.386] 	compiled for 1.20.8, module version = 0.5.0
[     2.386] 	Module class: X.Org Video Driver
[     2.386] 	ABI class: X.Org Video Driver, version 24.1
[     2.386] (II) LoadModule: "vesa"
[     2.386] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[     2.389] (II) Module vesa: vendor="X.Org Foundation"
[     2.389] 	compiled for 1.20.9, module version = 2.5.0
[     2.389] 	Module class: X.Org Video Driver
[     2.389] 	ABI class: X.Org Video Driver, version 24.1
[     2.389] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[     2.389] (II) intel: Driver for Intel(R) HD Graphics
[     2.389] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[     2.389] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[     2.389] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[     2.389] (II) FBDEV: driver for framebuffer: fbdev
[     2.389] (II) VESA: driver for VESA chipsets: vesa
[     2.663] intel: waited 0 ms for i915.ko driver to load
[     2.663] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20200715
[     2.663] (II) intel(0): SNA compiled from 2.99.917-913-g9236c582
[     2.663] (WW) Falling back to old probe method for modesetting
[     2.664] (WW) Falling back to old probe method for fbdev
[     2.664] (II) Loading sub module "fbdevhw"
[     2.664] (II) LoadModule: "fbdevhw"
[     2.664] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[     2.664] (II) Module fbdevhw: vendor="X.Org Foundation"
[     2.664] 	compiled for 1.20.10, module version = 0.0.2
[     2.664] 	ABI class: X.Org Video Driver, version 24.1
[     2.664] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 520
[     2.665] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 2 threads
[     2.665] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[     2.665] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[     2.665] (==) intel(0): RGB weight 888
[     2.665] (==) intel(0): Default visual is TrueColor
[     2.786] (II) intel(0): Output eDP1 has no monitor section
[     2.786] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[     2.786] (II) intel(0): Enabled output eDP1
[     2.786] (II) intel(0): Output DP1 has no monitor section
[     2.786] (II) intel(0): Enabled output DP1
[     2.787] (II) intel(0): Output HDMI1 has no monitor section
[     2.787] (II) intel(0): Enabled output HDMI1
[     2.787] (II) intel(0): Output DP2 has no monitor section
[     2.787] (II) intel(0): Enabled output DP2
[     2.787] (II) intel(0): Output HDMI2 has no monitor section
[     2.787] (II) intel(0): Enabled output HDMI2
[     2.787] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[     2.787] (II) intel(0): Output VIRTUAL1 has no monitor section
[     2.787] (II) intel(0): Enabled output VIRTUAL1
[     2.787] (--) intel(0): Output eDP1 using initial mode 1920x1080 on pipe 0
[     2.787] (==) intel(0): TearFree disabled
[     2.788] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[     2.788] (==) intel(0): DPI set to (96, 96)
[     2.788] (II) Loading sub module "dri3"
[     2.788] (II) LoadModule: "dri3"
[     2.788] (II) Module "dri3" already built-in
[     2.788] (II) Loading sub module "dri2"
[     2.788] (II) LoadModule: "dri2"
[     2.788] (II) Module "dri2" already built-in
[     2.788] (II) Loading sub module "present"
[     2.788] (II) LoadModule: "present"
[     2.788] (II) Module "present" already built-in
[     2.788] (II) UnloadModule: "modesetting"
[     2.788] (II) Unloading modesetting
[     2.789] (II) UnloadModule: "fbdev"
[     2.789] (II) Unloading fbdev
[     2.789] (II) UnloadSubModule: "fbdevhw"
[     2.789] (II) Unloading fbdevhw
[     2.789] (II) UnloadModule: "vesa"
[     2.789] (II) Unloading vesa
[     2.790] (II) intel(0): SNA initialized with Skylake (gen9) backend
[     2.790] (==) intel(0): Backing store enabled
[     2.790] (==) intel(0): Silken mouse disabled
[     2.790] (II) intel(0): HW Cursor enabled
[     2.791] (==) intel(0): DPMS enabled
[     2.799] (==) intel(0): Display hotplug detection enabled
[     2.799] (II) intel(0): [DRI2] Setup complete
[     2.799] (II) intel(0): [DRI2]   DRI driver: i965
[     2.799] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[     2.799] (II) intel(0): direct rendering: DRI2 DRI3 enabled
[     2.799] (II) intel(0): hardware support for Present enabled
[     2.799] (II) Initializing extension Generic Event Extension
[     2.799] (II) Initializing extension SHAPE
[     2.800] (II) Initializing extension MIT-SHM
[     2.800] (II) Initializing extension XInputExtension
[     2.800] (II) Initializing extension XTEST
[     2.801] (II) Initializing extension BIG-REQUESTS
[     2.801] (II) Initializing extension SYNC
[     2.801] (II) Initializing extension XKEYBOARD
[     2.801] (II) Initializing extension XC-MISC
[     2.801] (II) Initializing extension SECURITY
[     2.801] (II) Initializing extension XFIXES
[     2.802] (II) Initializing extension RENDER
[     2.802] (II) Initializing extension RANDR
[     2.802] (II) Initializing extension COMPOSITE
[     2.802] (II) Initializing extension DAMAGE
[     2.802] (II) Initializing extension MIT-SCREEN-SAVER
[     2.802] (II) Initializing extension DOUBLE-BUFFER
[     2.802] (II) Initializing extension RECORD
[     2.802] (II) Initializing extension DPMS
[     2.802] (II) Initializing extension Present
[     2.802] (II) Initializing extension DRI3
[     2.803] (II) Initializing extension X-Resource
[     2.803] (II) Initializing extension XVideo
[     2.803] (II) Initializing extension XVideo-MotionCompensation
[     2.803] (II) Initializing extension GLX
[     2.826] (II) AIGLX: Loaded and initialized i965
[     2.826] (II) GLX: Initialized DRI2 GL provider for screen 0
[     2.826] (II) Initializing extension XFree86-VidModeExtension
[     2.826] (II) Initializing extension XFree86-DGA
[     2.826] (II) Initializing extension XFree86-DRI
[     2.826] (II) Initializing extension DRI2
[     2.830] (II) intel(0): switch to mode 1920x

Thanks @Dobbie03

Funny thing, after installing GDM at TTY, LightDM was my login screen lulz, so I posted the truncated log while after using LightDM for login. As usual, AL is fine, no issues whatsoever, it’s just a matter of I solving an issue that to me is not much of one, although a bit different as I hardly ever had issues with a login screen, so thus why need some guidance. I might scrap everything for xinit once I learn how to use it lulz.

pacman -S xorg-xinit
echo 'exec openbox' > ~/.xinitrc

Then run startx

2 Likes

That’s a normal X session with no errors. How about the LightDM log?

1 Like

I’ll post that later. I had an accident putting up the xmas lights where I fell off the ladder and borked my back lulz. Right now laid up until the doctor visit. Thanks to everyone for the help though, will get ‘back’ to it soon.

Wholy crap, hope you ll get better soon @drummer

@altman Yeah it happens, and thanks for the well wishes.

Update: With a searing lower back, I decided to do a full reinstall, but without a display manager, so I apologize for no logs in case one wanted to see what bugs were in my install. I opted for the vanilla kernel instead of the usual Zen at install, just to make sure there wasn’t a issue there. The only issue I had was due to the former Zen image still installed, so I deleted both the default and fallback Zen images, and rebooted into autologin with xinit as the DM. Now it’s just a matter of I knowing how to get in and out of other WM’s using xinit, but that’s a good thing as I wanted to use that for a while instead of DM’s, and I was not as motivated until this point. So far so good, AL back up and running fine, might install Zen at a later date, or not. Ran out of booze for pain lulz, don’t have anything else except for Icy Hot patches and aspirin, had nephew finish lights, fall was a short distance but enough for my old ass to break lulz.

No problem @drummer .

Good that you know why it didn t worked because of some zen kernel bits here & there.

Edit: I use Advil Extra Strenght for my shoulders & lower back pain, it works a bit, wonder if it could be of any help to you @drummer

1 Like

@drummer Get better soon.

It should have nothing to do with the zen kernel . I am also using it with lightdm and xinit without any issue. Anyway, changing to use xinit is not a bad option. It’s simple and reliable.

1 Like

Just a matter of setting up the ~/.xinitrc for multiple window managers.

2 Likes

@altman A few years ago I had a very serious accident that eventually wound up with me having a total knee replacement, and that was the most pain I had ever, ever felt, post op. It felt like someone was tearing my lower leg off from the knee down. For six months I couldn’t walk, the next six my leg was bent at the knee, then the knee replacement, which took a few months to get used to, and for the most part I can do mostly everything I was able to do prior, maybe not run the mile lol, but miracles of modern medicine man. But hell if I ever want to have to go through that pain ever again lulz.

@chroot Yeah I never had any problems with the Zen before, but I also never had problems with LightDM before, so I just went vanilla this run. I use the Liquorix one in Debian, had the Xanmod one too. This is all on a laptop, so I dunno if they really make a difference either way, maybe in battery time, maybe not. I don’t game or do any graphics or hardcore video rendering, just Vapoursynth in mpv, being that I used to to madvr in Windows for playback, which is I guess hardcore rendering lol, but not in like video editing, or Blender, that sort of rendering. I used to cut in Avid when I worked in broadcasting ages ago, don’t do much of that lately however.

@PackRat Cool, thanks for the tip. Like I said earlier, I eventually was going to just go xinit, but as you can see how I futz with all the other distros, it’s just something I didn’t make a priority of. After the New Year, I am gonna focus more on learning code, and keep it more simple. Seeing what you all do here inspires me to get to that level, so hopefully by this time next year I will be able to do more with all this.

2 Likes