Latest ISO may 04, install problems and suggestions

So, after I had problems and reported it on another topic I tried the latest ISO and updated the installer to version 2.1.47 before starting the installation and it worked almost 100%, more like 98%, lol!

Here is my setup: external USB 3.0, 2 partitions (#1: esp/fat32 128M and #2: luks/ext4 32GB)

I noticed the following problems during installation:

The installer always picked a wrong (slow) mirror (I live in Brazil, South America):

The archlabs 1st mirror (sourceforge) from pacman.conf is always broken;

Even though I used DIST=’XyzXyz’ option, during boot up I can see the message “Welcome to Archlabs Linux” in blue scrolling very fast;

During final portion of the installation I got an error message, took a photo (attached at the end of this post);

Now some suggestions for the next ISO’s:

Make some scripts to update installer and pacman.conf (archlabs mirrors) so the user can just update the installer instead of the whole ISO (just like Anarchy Installer does);

Make instructions clear on how to use it in the “Welcome screen”;

Give the user an option to select the mirror by country, IMO this one is very important! (I think this option was available in previous versions??);

Sorry to bombard you guys with this long post, but I really like archlabs!

Thanks for this great project!

archlabs

Thanks for the feedback.
Just a note about updating installer - you can connect to the network with nmtui-connect script and then run pacman -Syy archlabs-installer to get the latest version of installer before you run it.

2 Likes

@dimaom yes, that’s what I did, also edited pacman.conf and mirrorlist manually before starting the installer.
But maybe something like “update-installer” would.be easier for the user.
Thanks for replying!

Edit: BTW, do you have any idea what is the error I reported in the attached image? TIA

It’s almost impossible to say without knowing to which package “4/21” refers. I don’t suppose you remember? The fact that the previous line references creating temporary files would suggest that it isn’t critical.

1 Like

Hey man don’t feel bad about the long post, I love constructive feedback and I know everyone here appreciates the enthusiasm for ArchLabs.


Indeed this should be fixed.

Regarding the error in the attached image, it can be ignored in this case. Many of the commands in systemd or other package updates that try to check /proc are unaware that they are running in a chroot and fail, as HoaS said it’s not crititcal. If it was a real problem/error pacman would fail to do the operation and you’d be presented with whatever it output to stderr.

The mirror issues will be looked into as many people seem to be having issues, for clarity all were doing is running reflector in the host then copying the mirror file into the new system after installing base or copying the iso. We don’t offer by-country anymore because it’s not entirely relevant; mirrors in neighbouring countries may be faster and you’d never know so we only rate by speed.

reflector --verbose --score 80 -l 40 -f 5 --sort rate --save /etc/pacman.d/mirrorlist

@Head_on_a_Stick and @natemaia thank you both for your replies!
Hope you fix these small annoyances in the installer, count on me for “beta testing” any new release!

I think I fixed most of the issues you brought up here as well as some others, the latest version is packaged in our unstable repo (2.1.51, actually a bit old but it will auto-update itself to the latest). To enable the unstable repo you need to uncomment the entry in /etc/pacman.conf then run

pacman -Syy archlabs-installer

The executable name has been changed to just

installer
1 Like

Question: what is your computer’s setup? Is it a desktop or a laptop, and what are its hardware specs?

@natemaia wow, the new menus are cool and the option to select the mirrors is great!
But I had some problems:
1 - Keymap say it defaults to US, however the first option was selected (don’t remember the language). Not a problem, but it is not coherent with the text;
2 - When trying to setup LUKS in VirtualBox, I got stuck/loop when selecting “basic” or “advanced” (I had 3 partitions created 1-MBR, 2-FAT32, 3-Ext4) the script returns to the same page.
3- When I decided to go ahead without LUKS when mounting partition the script aborted with error: “usr/bin/installer: line 1477: -1: substring expression <0” (image attached)
At this point I could not proceed…
I used again DIST='Distroxxx" option and it seems to work perfect until the installer failed…
The script “auto update” worked 100%, it updated itself to ver 2.1.53!
I am ready for further testings, thanks for you work!

1 Like

Can you post a screenshot or the output from lsblk -fa on the system before starting the installer?

1 Like

Another update that should fix the error in your screenshot.

1 Like

I am away from home, will try again tomorrow and report!