Keyring issue got me at boot, I already reinstalled the entire system - for some reason apps are ignoring old config files

Hi. I had updated my system and after reboot there was missing /vm-linuz msg, I didn’t really know how to deal with it. I tried chrooting but couldn’t get it fixed, so I decided to reinstall the entire system as that would be the quickest for me.

However now that I have reinstalled, trying new kernel (zen) I am noticing some weird stuff in my system. For example, nano was not installed by default, system is not using my old .config files for many apps, like openbox, gimp, tint2, even desktop wallpaper is not right.

On my first attempt to use zen kernel, I couldn’t log in because the graphics looked “messed up” while the green boot messages appeared. So I reinstalled - figured I need some extra packages to fix that issue like linux-zen linux-zen-headers nvidia-dkms – so I reinstalled again, and added these as a “run command after installation”


I booted archlabs installer from my old usb and here is what I did:

pacman -Syy archlabs-installer
archlabs-installer

Mounted partitions, formatted my sda drive.
Chose Zen kernel
Chose a bootloader (there were 2 options, I chose the other one which was not Grub)

“Commands to run after installation”: pacman -S linux-zen linux-zen-headers nvidia nvidia-libgl nvidia-dkms

Now the weird graphic glitch was gone and I could boot into the system. However it feels like base (or) base-devel packages did not install for some reason, I wonder why? Because I didn’t have nano editor installed I figured this may be the case.

What to do? Most of my apps are ignoring the configs in .config, I think I should reinstall one more time. Not sure what I did wrong… but I do want to test running zen kernel, because I am getting occasional crashes with the vanilla kernel.

Regarding the editor, nano isn’t part of base, unless you select something else from the package menu all you get is vi.

I’m not sure what you mean by this, can you provide an example? Were your old configs overwritten?

I don’t know, but the last time I installed ArchLabs (with vanilla kernel) I didn’t have to ever install nano I think. Could it be that my configs were overwritten, was this to be even expected this time?

For example, after reinstalling the system yesterday with the zen kernel. The background image which I had once set was no longer active (AL mountains bg is active), I had specifically disabled Rofi from using “super key” (but reverted now). I had configured Openbox to have “desktop names” but it is not active, even though I can find the old configs. My Gimp installation had custom presets, which are “gone inside Gimp” (but I am sure the old configs exist).

Problem: my custom config files seem to be existing and all, but they are not getting used for some reason.

What I am trying to suggest is that if I’d re-install AL the same way again, but I’m going to choose vanilla-kernel “I think” my original configs will work right off the bat after installation is complete.

I don’t know why this is even happening, at first I thought because of the custom commands I ran after installation (inside AL installer).

I think nano came installed by default early on.

Maybe you mentioned this earlier and I missed it, but how did you do the install? Did you attempt to keep your preexisting /home partition with your configurations and now they are not being read?

Or did you do a clean install and copy your configuration files to the new install?

Did you copy them over after a clean install? Sometimes the ownership and permissions get messed up when you do that.

1 Like

Arch replaced the old base group with a slimmed-down base metapackage and nano was dropped:

https://www.archlinux.org/packages/core/any/base/

Archers are now expected to use cat > $file << EOF like a real programmer :grin:

1 Like
  1. I formatted /dev/sda
  2. Kept preexisting /home in /dev/sdb (all stuff is here, just .configs are not being read by system)
  3. I copied nothing, I reinstalled AL a few times, never had to copy anything. /home .configs were used instantly on the first boot up

This is lsblk output with 2 SSD’s

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 465.8G 0 disk
├─sda1 8:1 0 512M 0 part /boot
└─sda2 8:2 0 465.3G 0 part /
sdb 8:16 0 465.8G 0 disk
└─sdb1 8:17 0 465.8G 0 part /home

The only thing I have different, is zen-kernel and thus I guess some different bootloader (which doesn’t seem to be efibootmgr nor Grub. I’ve never ran zen-kernel before so apologizes for my stupidity /lack of knowledge here. Previously I used vanilla-kernel, since i started using AL. So far I am not looking to revert back, as the performance with zen-kernel seems totally different (better) to me.

But installing the zen-kernel from AL installer seems edgy! Cause it needs those headers too in order to properly boot, from my experience at least. And the headers are not included by default by the installer, resulting in a “buggy installation” where you can’t even boot into the system (technically you can, but you can’t read anything due to ‘graphic glitches’.

Maybe there is a link between switching the kernels around, why I am having this problem…? I got no idea. I am willing to do re-install, to even test if vanilla-kernel will “restore” what I had before and if the configs magically start being read. I don’t know, I am open for suggestions :slight_smile:

The headers are only needed because you use the proprietary NVIDIA drivers.

1 Like

Thanks for pointing it out! I didn’t knew that specifically. Did I do the right thing then to run this command in the archlabs-installer (after the install finished)? // Would really love to know for the future, as I think I plan running zen kernel on this machine exclusively from now on.

pacman -S linux-zen linux-zen-headers nvidia nvidia-libgl nvidia-dkms

I wish the installer itself knew to suggest installing the required packages after choosing the kernel, based on the graphics card you are running :smiley: because as a first timer to some new kernel, I wouldn’t expect my system to not properly boot up after the installation. But that did happen (glitchy graphical “boot up texts” frozen).


Edit: I think I got a bit carried away! But the .configs aren’t still being read for whatever mystical reason, hopefully this will not become a thing between AL re-installs in the future :stuck_out_tongue: now that I have found my favorite kernel!

This is really a user issue. There’s nowhere in the installer or our packages that we say “ignore these configs”. Gonna have to go through and test a single application and see what it is loading.

The installer does have the ability to install nvidia proprietary drivers but it’s not enabled by default, read the installer help -h output.

Sorry for the delayed response…

Yes, that looks good to me. The headers are needed to build the kernel module and the dkms package ensures that happens when the kernel is updated.

The nouveau drivers work quite well with NVIDIA cards these days (apparently) so the blobs are hardly “required” :wink: