Kernel panick on Vanilla

Hi
Since yesterday, I have the following when trying to boot into vanilla kernel
LTS is still fine.
I think the first two errors about ACPI have always been there. I think
I can easily jut use LTS and wait for the problem to go away, but any ideas, please?

Not sure if this plays a part in anything but there was also a Grub update yesterday.

2 Likes

Thanks @sammiev
maybe, could be
The second time I tried to boot (after the kernel panic) a Grub file was missing (I am 90% sure it was initramfs-linux.img or very similar).
I then ran update-grub which got the file back, but didnt stop the panic

oh well, LTS it is then - I dont notice any difference between the two

I was just curious to hear if others had the same problem / if there was an easy fix

1 Like

Have you tried to re-install the kernel? If you have any other storage(usb, dvd, external hd, etc) attached to the system, detach them before reboot.

$sudo pacman -Rns linux linux-headers

$sudo pacman -Sc

$sudo pacman -S linux linux-headers

$sudo reboot
2 Likes

Thanks @chroot

does that include an ssd in a dvd caddy?
Its kind of an ‘internal’ (physically) external hd / DVD!

[EDIT: I am searching for this kernel reinstallation and I cant find any mention of removing external storage. I am mentioning this to try to understand why - I obviously know that you know what you are talking about :slight_smile: ]

Actually, sda is my Lappy original internal HD, with Windows on it & sdb is the HD in he DVD caddy, with ArchLabs on it:

I waited a few kernel updates but still the same problem, so I tried the below, but no luck :frowning:

LTS still fine

This fixed it :smiley: :+1:

leigh@archlabs ~ % sudo update-grub
2 Likes