Is anyone here using Kitty as their terminal?

So st was doing some frustrating things that I couldn’t be bothered to investigate to fix and in the mean time I have installed and have been using Kitty.

It’s nice, I like it. Anyone else use it? Any thoughts?

never tried it…

AFAIK @nwg swears alacritty is the best thing to use on anything wayland based

I really like xfce4-terminal for x11 setups. To me it’s what termite should be and is in between the vte and suckless/xresources world.

Nop, still on my old Sakura on my side.

Heard about Kitty here in the forum but never tried it.

I used it for a bit, its nice but I wasnt a fan of some of the configuration and the developer is pretty self centered. Ultimately I just stick with xfce4-terminal because I’m lazy and it just works and has the features I use

1 Like

It’s pretty nice — loads of options and the text rendering is bang-on, even for the usually troublesome alsamixer bars & lines.

The only problem I can see is the memory usage:

 32.5 MiB +   6.9 MiB =  39.5 MiB       kitty
  7.2 MiB +   1.3 MiB =   8.5 MiB       x-terminal-emul

^ That’s from my Debian buster box, the second line is for xterm.

I use it every now and then. If you like using dwm (tilers in general) the tiling layouts feature is good. I haven’t power used it beyond that though.

Hoas is right though, resource hungry and needs a newer GPU - my older HP won’t run it or alacrity. Have to stick with urxvt+tmux on that laptop.

Kitty is also recommended. Personally I prefer Alacritty, even if it sucks on X11. Who cares of X Windows? :roll_eyes:

I tried installing it. Installs fine, but does not run at all, since my m/c is quite old (a 2009 HP); it quits with complaint “old or broken … openGL”.

Hey, I’m happy w/ my xfce4, sakura, st, tilix. Those are all top.

Btw, check out (just for a small kick) edex-ui, its based on Tron sci-fi terminal. It ran fine on my old m/c too, but its not something you can live with daily. Uninstalled within the hour.

Tried installing that today in Debian since their repos don’t have a package for it, yet. I saw that I had to install more dependencies to compile it, and said fuggedaboutit and installed Kitty instead lol.

adi-Archcraft had that in one of his Archiso builds before it eventually became Archcraft. I installed one of those a while back. My little 5 year old grand nephew thought edex was the coolest thing ever. For about ten minutes, because he as well as I didn’t know what to do with it lulz. He went back to playing a game on his iPad. Yeah he has an iPad at that age, my sister bought it for him on his first birthday. I just shook my head at that. I wound up giving him a guitar I had lying around so he could do something else with his hands.

I installed both Kitty and Alacritty but because Kitty had a small issue with displaying icons I never bothered to dig deeper into it’s configs to solve it so I stuck with Alacritty.