Intel gpu not compatible with last kernels

A few times ago i was reporting that my system froze after the 5.3.X kernel install, apparently i wasn’t the only one, and the problem is known by a lot of intel users since the 5.3 kernels, no fix for 5.4.X, and there will be no fix for 5.5.X. (…)

If you have the same problem and can’t use your system you will have to downgrade to 5.2.X and stay on it, if you have it in your pkg archive it will fix your problem. My post is just here to give the information, I don’t expect for someone to give me the fix, it must be complicated.
And like a lot of people I wait until something is officially done.
Here a link:
https://linuxreviews.org/Linux_Kernel_5.5_Will_Not_Fix_The_Frequent_Intel_GPU_Hangs_In_Recent_Kernels

1 Like

A better option would be to change to the LTS kernel, running an outdated kernel version is not wise.

EDIT: and it’s not just Intel users who are suffering:

https://www.phoronix.com/scan.php?page=news_item&px=AMD-Restore-Retry-Faults-Raven

3 Likes

I thought that it would be resolved with 5.5 so I waited.
But now that I see it was useless, seems that it’s indeed time to install LTS

Thx for sharing @k43r17h , as stated in link provided, it s getting bad to worst, bet that it might take some times to resolve.

Done. LTS installed without problem.
kernel, kernel-headers, and doing a grub-mkconfig was required.
I select it in the grub for now.
Since it’s intel I don’t really know if it’s useful to do something anything particular about the graphic driver but eh, it works so I think it’s ok, I will do the usual and test everything.
Thx and good luck to those who will attempt to try to fix things by themselves.

Glad that you got it to work @k43r17h . I would stick to this kernel for a while.

Thx to @Head_on_a_Stick for the solution.

Hi, sorry if I disturb you, but you should change the title of the discussion, I have intel gpu and I don’t find these problems.
Ector
Cheers
edit
on some old distros I still have the 4.8.4 kernel, and it works without problems, some programs don’t work, like vlc and more, but the distro still starts with that kernel.

After the new update of the lts kernel (5.4.x) it’s broken again, so I tried the last normal kernel (5.8.x), still the same…
Oh boy.

Is that the mainline kernel or LTS , @k43r17h

The mainline kernel and the lts kernel.
I think I should test the 5.2 (or 5.1) since it’s bugged starting from 5.3.x.
But I have never installed a kernel without using the repos before. Is it possible to download it from kernel.org and simply pacman -U (or make etc…) it ?

I would stick with ths LTS kernel, having too many kernel s not a good thing.

I would use the one from arch s repo

https://www.archlinux.org/packages/?name=linux-lts

https://www.archlinux.org/packages/?sort=&q=linux-lts+&maintainer=&flagged=

I would remove the mian kernel as it gets issues with your install.

this one in your links is the newly updated version of lts (5.4), it’s the one wich is now bugged for me… (lts is bugged too now)

Oh, do you still have the other lts kernel that was working ok on your install !

If so reboot to the other kernel then remove the last kernel that was updated that doesn t work for you.

No that’s why i’m stuck, i could have downgraded it simply by selectin it in/var/cache/pacman/pkg/, I have made a mistake by clearing the cache few weeks ago.

oh, gotta find a way to downgrade

It s part of arch s way of updating which can be risky some times sadly.

I would install this one, & don t update the kernel for a while till they fixe the issue(s)

https://archlinux.pkgs.org/rolling/archlinux-core-x86_64/linux-lts-5.4.24-1-x86_64.pkg.tar.zst.html

Also have a look @ the arch forums concerning lts kernel issues here & there.

it’s still a 5.4.x kernel, and the issue exists since 5.3
:confused:

oh ok, what was the last lts kernel that was ok for you.

I don’t remember the exact version, 4.5.19 I think.