Installs on nvme0n1 drives

Anyone enjoying install failure on nvme0n1 drives. Either auto install or manual partitioning?
Initially the install begins but after a few mins, pacstrap begins to fail installing packages.
On a second attempt, I opted to only install a WM and bypass adding apps etc.
Same thing, pacstrap fails.
Unfortunately, I did not gather the error info verbatim. Just curious if anyone else has.

Welp - I was able to capture an image with the iPad.
Notice it seem to go through all the motions then, bam… This appears.

1 Like

Which iso are you using?

You need to update the installer first; the post by @Beast has a link to a beta iso that you can try.

After the update, the command to install is:


not archlabs-installer.


What @PackRat said, 2.1.46 is quite old at this point and you should update the installer first.


Is there a particular ISO I ought to be using? I tried the May 4 ISO and even though I worked though the “fix” I still had errors and in the end, a large portion of the apps were not installed.
BTW - I did opt to manually partition as I normally would anyways.

I’m going to set this aside for a spell. I have a feeling I am just not seeing something clearly on my side. Need to step back and stop looking for a complex problem when in fact, its prolly something stupidly-simple, lol!

The partitioning is rarely if ever a problem for the install, it’s always the packages and network.

We haven’t had a new iso in quite a while, I had another response in a similar thread about just this. Basically I’m too busy and unenthused atm to really work on a new iso, archiso has changed significantly so the build process will need a large overhaul.

I was able to get one built just now (7am on thanksgiving sunday before going to work) and I did a quick-n-dirty install, some minor issues with xinit login but a ^C followed by startx got it working. I also wouldn’t use the Copy ISO base install due to the archiso changes.

All in all I’m just not sure how much longer I’ll be willing to keep maintaining it, with all the work this summer and how tired I am generally I really just want to work on some of my own projects.

The installer is setup so it can be curled from an arch iso and it should all just work. One day I’ll write a short guide or something on this, maybe then the iso builds will be unnecessary.

1 Like

I hear ya! I follow eznix on YouTube and he did an installer using calimaries (spelling???)
and he too said that the Arch devs are changing things up and he pretty much put his project to the side - albeit that his installer is a personal project and meant for him but put it out there for whomever. So with all that, it kinda makes me think (the conspiracy) that the Arch changes are intentional (insert any nefarious reason :flushed: ).

That’s not the case, I can almost guarantee it. They’re finally putting some energy into archiso after it having numerous issues for years and using a few no-longer needed build procedures like EFI shells (on that note, it’s 2020 after all, why is BIOS support still even a thing when 32bit isn’t)

Calamares :rofl: Isn’t it already it’s own distribution independent installer? Calling something like that a personal project could be a bit misleading.

Ahhh - do I hear that perhaps an installer may take the place of the whole ISO? If that is a goal - that would certainly be easier (I would think) then maintaining the current state.

LOL - Im not sure really. I know that is part of it but it may be more a bunch of scripts that he created. Not sure bit found it interesting.

This has been the plan for a while and is already the case more-or-less, just needs some installs.

# boot iso and connect to network

pacman -S dialog
curl -fSL -o /usr/bin/installer


Should be all that is needed.


Nate!!! This one worked perfectly (the 10-11 iso - BTW, is a nice B-day gift to me too, lol )!
Running it now.

1 Like

Did a clean install with this method no problems.

From an arch iso?

Yes, I downloaded the June beta iso and used it.

Simple install, just a root partition and swapfile (file not partition). Install went without issue. Installed Fluxbox without a DM, just using startx.

Grub found Windows 10 no problem, dual boot working.

This is an older (2011) HP so no uEFI. Grub installed to MBR by default; didn’t get the usual step asking where to install the boot loader. Can’t remember if that is the norm for legacy BIOS, one harddrive.

Edit - next step is getting yaxwm installed.

Straight Arch? No
June beta of ArchLabs.

Did select the option to download the packages, not copy from iso.

It was pretty quick, maybe I’ll try again with an Arch iso.

Failed trying to install from a plain Arch iso. Bunch of chroot pacman errors - file name changes etc …