Installing Archlabs keeps failing

Hello,

This is my first arch-based distro so I don’t know what to expect.

Anyway, I created a live USB from the ISO and I’ve been trying to install it since last night and every time it fails.

Sometimes the mirrors stop responding and the installation continues without some files and when it’s done the OS boots into the terminal.

Other times it fails to download some other files during installation and I boot into Openbox which looks weird with missing icons and lots of errors.

I honestly don’t know what to do.

Today, I attempted another installation and it booted into a weird looking Openbox and with missing icons and lots of errors as well.

Is it possible to fix this from the terminal or what should I do?

Screenshots of the installation errors and how openbox looks

https://imgur.com/a/YS0Xy9f

That window manager in the screensot is not openbox, that is dk window manager. A tiling window manager similar to dwm. That is the default set up.

Did you answer “yes” to skip that archlabs-obkey package?

You can try an install but do not select openbox. See if the installation completes, then you can install openbox with pacman.

1 Like

But I selected Openbox during installation.

And what about the missing icons and errors? I can’t even connect to wifi even though it’s detecting it.

it didn’t ask me for anything. I didn’t get the chance to select yes or no, it simply continued all on its own.

I will attempt another installation now without openbox and will select dk.

How were you trying to connect to your wireless network?

Did you try using nmtui? That’s the console based tool provided by network manager.

1 Like

I am able to connect to a wireless network during installation but not after I boot into the system. Then I get an error about incompatibility.

Kudos on your first venture into Arch via a text installer … not the easiest expedition!

Your screenshots look fine. You should have a default terminal emulator installed where you would just need to define it as the default emulator (Maybe in Preferences). Unlikely, but possible … if you don’t have an emulator installed, you will have to install one.

Maybe someone who uses openbox can chime in, or you could just do a google search on how to associate a terminal editor in openbox.

Wireless … check your wifi button in the top bar of your laptop. Or, I assume there should be a Network area in the Preferences.

2 Likes

I had the same thing. archlabs-obkey cannot be installed. It is missing python2.

3 Likes

Icons are missing because archlabs-icons is not installed. It can then be installed with pacman. The list is in the packages file in home.

2 Likes

I reinstalled archlabs and this time I selected both “dk” and “openbox”.

However, logging into dk doesn’t work and leaves me hanging on a blank page.

Logging into openbox works but with missing icons and lot of errors, it also looks raw and so out of place with the look-and-feel of archlabs. Light blue everywhere.

I managed to install the icons using pacman so that’s settled.

However, I am unable to install archlabs-obkey because I cannot install python2. I tried to install it with pacman but it says “cannot resolve”.

A quick google search shows that python2 has been shelved and no longer available.

How am I supposed to run this thing if it depends on a package that is no longer available?

python2 is on AUR but also gives some errors…

so what can I do now?

I can reattempt a reinstallation but since python2 is not resolving, I honestly don’t see the point.

  1. wait for a developer to call
  2. do you need an obkey?

I am not sure what I need, as I said this is my first arch-based distro and everything looks different here.

If the system needs it I guess it’s required.

Besides, the system is not being fully installed and I’m getting a lot of errors in Openbox and DK is just refusing to load.

Also, there are a lot of timeouts from github and bitbucket for some reason.

ObKey is the Openbox Key Editor. It can also be done in another editor.

1 Like

You don’t need him yet and someone else will write.

python2 has been moved to the AUR

you can use baph (the ArchLabs AUR package handler) to install it or any other package from the AUR.

baph -i python2

obkey is also in the AUR, but it is not required for openbox. It’s just a tool to edit key bindings; you can use any text editor for that.

1 Like

How are you logging in?
What are the errors?

1 Like

I mean the login page when you first boot the OS.

I don’t get any errors when I select “dk” as the WM but I only get a blank page after logging in.

When I enter openbox I get errors like “Failed to launch preferred application for category TerminalEmulator” and that’s just one of the errors. Many applications just don’t work.

On top of that I am getting too many “timeout” when downloading from github and bitbucket.

I am attempting yet another reinstall at the moment and I just received this error

Failed retrieving file “archlabs.db” from github…

Previously when I logged into openbox, it looked nothing like the default look of archlabs so something must be going wrong somewhere and it’s not being fully installed.

I just finished yet another reinstall and as usual, archlabs-icons are not installed.

So I tried to connect to my wireless network and got this error