Installer fails. no internet detected

I know this issue has cropped up here before and I’ve followed the various solutions but with no real luck.

Problem: The ArchLabs installer refuses to detect my internet connection. This is despite the fact there is an internet connection. Various pings, etc, always return a working connection.

When it throws me into the “set up connection” menu with Activate/Deactivate" these options do nothing. The only thing that does work is unplugging my ethernet cable and plugging it back in…and then it detects the connection and lets me continue.

Problem solved, right? Alas no.

Once it hits that connection menu, any time I return the installer, even with a working connection, any text input into the terminal to complete the setup becomes corrupted. Incorrect characters, etc. It makes it impossible to complete the installation successfully. So I’m literally unable to install the OS.

I tried running the net program before the install (cannot remember the exact name) and it made no difference. So it seems I’m encountering two bugs here:

One, the installer not detecting my active connection.
Two, the terminal character input becomes corrupt after encountering any kind of issue with the installer, even if you manage to re-run it.

I did manage to get through the installer at least once by just using default “returns” or managing to input the correct character by hunting and pecking…but made a huge mistake at the end (and this is user error). On the confirmation screen, I neglected to notice it had selected the wrong drive to do the install on, despite the fact I know I selected the correct one. It instead selected my windows drive and…yeah. User error there though.

Wow, this is an interesting issue. @natemaia have you got any ideas here?

I’m wondering if it’s possible to edit the script to remove the “internet check” step. It will still download packages because there is a connection. I just need to make it past that check step so it doesn’t close out and have corrupted text should I re-start.

Not sure about the corrupted input but I just pushed an update with a new flag to allow skipping the network check -c, without being able to pass this means you’ll need to update the script manually

curl -fSL https://bitbucket.org/archlabslinux/installer/raw/master/installer -o /usr/local/bin/installer

For clarity’s sake the way it checks the network connection is (on real hardware)

ping -qc1 'archlinux.org' > /dev/null 2>&1

So I really don’t see how you’re getting successful responses if it doesn’t, can you post the commands you used to check your connection and their output?

So what’s happening is this:

By default it does not detect internet and this throws me into the connection wizard.

  1. The wizard doesn’t work, nothing I do there will activate my connection.
  2. However, if I unplug my internet at this stage and plug it back in and hit “Quit” it suddenly does detect it and allow me to advance through the installer.
  3. The new problem is, once this occurs, any text input in the terminal becomes corrupted. Letters become other letters or no letters at all, spacebar stops working, etc.
  4. So in the end, even through I can work around the connection issue, it causes another issue with input that disallows me to complete a successful installation.

I’m able to use ping before running the installer and get returned results with no issue. I’ve also tried nmtui. In additional, I’ve checked my bios and the correct date/time is set there as well.

Thanks. I tried this. The new installer does download using curl, however, trying to pass the -c flag results in an invalid option message

installer -c

Also tried editing the install script itself with nano but even with changes, the same problem keeps coming up: it takes me to the network setup message.

I was wrong on one thing: Pings to archlinux or anywhere else before running the installer do not work. They return a routing message.

Ok I found what’s going on, a few things have changed with the build and I’m still getting used to it apologies (installer is in /usr/local, not /usr).

To grab the installer do

curl -fSL https://bitbucket.org/archlabslinux/installer/raw/master/installer -o /usr/local/bin/installer

# or if you already downloaded it to /usr/bin
cp /usr/bin/installer /usr/local/bin/installer
1 Like

I’ll give it a shot! Thanks!

Appreciate the help but it looks futile for me at least.

The installer -c flag won’t pass. But, even if it did, I think my problem is that there is zero way for me to initialize the network connection without running nmtui.

The problem is, running nmtui gives me the corrupt input problem.

If it’s a problem for others, it might be worth looking into but I certainly won’t ask you to spend time on this for just myself.

I did edit the new installer file and remove the network check so it was bypassed. It still won’t work because I suspect it really does need nmtui to get past the problem. I know I read somewhere that one of these terminals has an issue like this, but I’m not sure which. Maybe ZSH? Perhaps the fix is using another terminal that doesn’t have this input corruption after running nmtui.

So to recap:

The install disk will not detect my internet connection, but, does allow me to execute the curl command to download the new script.
I am forced to use nmtui at some point to re-setup the net connection.
Anytime I enter nmtui, from that point on until I reboot, I will have character input issues where the correct key mappings are not observed.

End result: I cannot get through the setup process.

Does this happen with a different distro and installer or just with the AL installer? What are your computer specs?

Only Archlabs. I’ve installed the following over the last week as I played around (and not in a vm)

Arch vanilla
Gentoo
NixOS
Manjaro

Specs: Ryzen 3900x
AMD 5700XT
32 Gigs of Ram
And I can’t remember the exact model MB but it’s an Aorus something.

You can connect with nmcli instead, that doesn’t invoke a curses interface:

nmcli device wifi connect "$ssid" password "$password"

Replace $ssid with the name of the access point and replace $password with the actual password.

1 Like

What kinda connection are you trying to use, wired or wireless? Can you post output from the following cmds after you think your connection is established,

$lspci -v

and

$ip a

Also, I usually skip the network configuration step if my connection is already up prior to the installer. Haven’t tried it in AL installer, not sure if it works in AL.

Wired. I’ll have to use another live disk for another distro to run those commands since I can’t do it via arc labs. I’ll do that and post details.

If you’re able to run commands in the live boot you could try a manual install, the guide is very fresh and some things may be missing but it should get a bootable system with most of the AL customizations.

1 Like