Installer ends in monitor turning off


#1

Hello, I hope you don’t mind me asking with another problem.
I switched to a vega 64 and now my monitors turn off when I try to start the archlabs installer. After selecting ‘ArchLabs Linux x86_64’ I come to the point when it says triggering events, a cpl of more lines and then the monitor turns off. Tried it with all 3 attached and then with only 1 monitor connected.
Result is the same, the turned off monitor. It happens with both, uefi and legacy.
Any ideas?


#2

https://bugs.archlinux.org/task/59755


#3

So it’s a lost cause right now?


#4

Looks like it might be fixed for kernel 4.20-rc4:

https://bugs.freedesktop.org/show_bug.cgi?id=107690

Have you tried the LTS kernel?

https://www.archlinux.org/packages/core/x86_64/linux-lts/


#5

I can boot and install arch just fine(4.20 kernel), but as I’d install what’s used with AL anyways I thought I’d save some time and work and install AL.
But without getting the installer to work I’m a bit lost.
Can I somehow use another kernel with the installer?
Sorry, I’m not intentionally stupid. :slight_smile:


#6

Give some info on the hardware, graphic drivers . Might help somehow.

inxi -G or other outputs from terminal.


#7

I’m not sure but you could certainly install a standard system with the installer then chroot in afterwards and change the kernel.

If the main system partition is on /dev/sda1 (for example), then

mount /dev/sda1 /mnt
arch-chroot /mnt
pacman -Syu linux-lts
grub-mkconfig -o /boot/grub/grub.cfg
exit
reboot

(If /boot is on a separate partition then you will have to mount that as well before running arch-chroot.)


#8

Tbh I have no idea what drivers the installer is using. Whatever’s happening between uevents and turning off my screens is happening too quickly that I could see it.
Hardware is:

  • MSI x370 gaming pro carbon
  • ryzen 7 1700
  • 16gig trident-z rgb
  • Asus strix vega 64

here’s inxi from my arch install:
Graphics:
Device-1: AMD Vega 10 XL/XT [Radeon RX Vega 56/64] driver: amdgpu v: kernel
Display: x11 server: X.org 1.20.3 driver: amdgpu unloaded: modesetting
resolution:
OpenGL:
renderer: Radeon RX Vega (VEGA10 DRM 3.27.0 4.20.0-arch1-1-ARCH LLVM 7.0.0)
v: 4.5 Mesa 18.3.1

@Head_on_a_Stick
If I got you right, I’d have to install archlabs for that though, right? The Archlabs installer is not even showing.


#9

Ah well, that won’t work then. Sorry.


#10

Wonder if you ll have to either reinstall or your iso disk is corrupted, never know.


#11

With my current setup there is no installer and I therefor cannot install archlabs at all right now. :slight_smile:
what does work is the regular arch linux with the 4.20 kernel.
I have used nvidia for the last I-don’t-know-how-many-years, to avoid removing everything nvidia related and my lack of knowledge regarding this, I wanted to set up everything new.
I guess I have to install AL with a different GPU then, remove everything nvidia related once archlabs is installed, switch gpu back to the vega and install amdgpu drivers?
I had some hope that I could maybe boot with arch linux, mount the archlabs iso and install archlabs while having the archlinux iso booted.


#12

Hi guys,

There is a nice guide where it is explained how to rebuild an ArchLabs-installer iso, it 's pretty straight forward to follow :
https://bitbucket.org/archlabslinux/iso/src/64d9a2f92715?at=master
It is what I did because I was in the same trouble as you’re right now (same graphic card) and it worked great even in a virtual machine.

I advice you to make a backup before the installation of the new iso just in case because I had a problem with os-prober ( may be it is coming from my hardware ssd/nvme0 ) it erased all my ESP partition. It wasn’t that bad for me because I had a backup from the day before but it could have been worst .
That doesn’t mean you 'll encounter the same situation but I thought that it could be nice to warn you .

Good luck :wink:


#13

First of all: thanks for your efforts, guys. Really appreciate it.

Just that I get a basic idea, with this method I create my own installer iso with the most up to date packages and therefor with the 4.20 kernel, did I get that right?


#14

Yes you get that right, sorry I didn’t tell it but yeah you 'll have an iso with the last packages so indeed a new kernel without that blocking bug .


#15

Might be my excitement speaking here, but that sounds awesome!
I’m on it and will give it a try.
Thanks again!

Edit: that just worked. :slight_smile:


#16

Glad it helped you mate .
:slight_smile: