Installer does not have btrfs support?


#1

Heya guys, I was just trying to install archlabs on my laptop that is using btrfs filesystem. I use that cause i have multiple installations in subvolumes. Well i booted up the archlabs iso and tried to install but at the mount partition option it didnt let me select btrfs as there was no option for it. That is a bit strange. The installer should at least support btrfs filesystem, would be even better if it actually supported btrfs subvolumes as the manjaro architect iso.
Anways i tried doing a pacman -Syu before loading the installer and also installed btrfs-progs but that did not help. The installer just doesnt support btrfs filesystems. So i guess the only available option i have is to shrink the btrs FS, create an ext4 partition to install archlabs and then move it to the btrfs FS… soo much work for something that seems pretty simple.
Hope somone found a way to get archlabs install to work on btrfs


#2

Never used it or always removed btrfs, but hopefully it can be of any help:

Edit: surprised that btrfs isn t supported already on the latest iso disk @Dobbie03 .


#3

Is that the newest release that you try to install @InvisibleRasta


#4

archlabs-2018.12.17.iso is what i am trying to install… i tried to install on btrfs fs with and without running pacman -Syyu before running archlabs-installer. but no btrfs support either way


#5

@Dobbie03 it would be really coolif you checked out the manjaro architect iso to see how they implemented the installer for btrfs with btrfs subvolume support too.


#6

Ok thx for the comeback, seems weird to me, hope that someone in the know will chim in for support.

Also their s the 2019.01 release on the ArchLab s site, but doesn t seem to be available for downloads.

https://archlabs.github.io/


#7

yeah i did notus that too today, it might be upcoming.anyway the site needs some fixing xD


#8

Guess that s a multiple installs that you have right !

Also; wonder if the iso that you have s corrupted somehow, might be the case.


#9

Guess I found it; From @PackRat s solution in that link;


#10

Does seems to to the trick.
Although, it would be nice if the iso ship it out of the box.


#11

Yep @gazeka74


#12

what solution sorry?


#13

Oh, second to last post from @PackRat in the link above.


#14

im not sure of what link you are talking about


#15

Just have a look at the post above yours. Edited , maybe you were searching in between.


#16

you mean this https://github.com/Baumgartl/archlabs-btrfs ?


#17

Look at 4 posts above this one.


#18

https://archlabs.github.io/ ?? sorry i dont understand what u are talking about. anyway i alredy solver with a dirty workaround.installed on ext4 and then rsynced on btrfs subvolume.


#19

It s alright glad that you fixed it, the link s posted 2 times in this thread already @InvisibleRasta.

Please post how you solved it, might help other people later on. & maybe for future use


#20

Dont know what link you are talking about to be honest. Anyway i alredy said how i solved it.
Installed archlabs on ext4 as it doesnt support btrfs
moved the installation to a btrfs subvolume with rsync
edited grub config and fstab accordingly