Installer do not find my second EFI partition

hello

I’ve a second EFI partition, reserved just for Linux
when I try to install Archlabs, the installer do not let me choose it,
it let me choose only the Windows EFI one, also if I have removed from it the BOOT flag

what should I do to choose the second EFI partition?

Sorry you’re having issues.

Can you post your partition layout and sizes with lsblk -fa

There is a way to pass in the root or boot partition if you already have it formatted and ready for mounting. You can also mount everything yourself and tell the installer

# correctly format your partitions before mounting
mount /dev/sda2 /mnt
mount /dev/sda1 /mnt/boot

installer -r /dev/sda2 -b /dev/sda1 -n
2 Likes

my second EFI partition is the last one in the SSD
I’ve tried to mount it like you wrote
but the installer does not find it anyway

maybe /mnt/boot/efi ?

Welcome in EFI system… :face_vomiting:

1 Like

Doesn’t help me much if I don’t know the layout and sizes. How big is it? Did you mount your partitions first and pass them to the installer? If you did it will start the install right away and leave you at a different menu without any mounting or storage management options.

Please post an image, error message, or anything that will help me see what going on.

2 Likes

This will give us a little more info as well.

lsblk -f
3 Likes

^ see my original response, need a bit of info to work with

2 Likes

my bad !

1 Like

here are the partitions:
sda

sda1
sda2
(the usb drive)

nvme0n1

nvme0n1p1 vfat (EFI of windows, too little space, just 260 MB, I’ve removed the BOOT flag)
nvme0n1p2
nvme0n1p3 Windows
nvme0n1p4 NTFS
nvme0n1p5 EXT4
nvme0n1p6 EXT4
nvme0n1p7 SWAP
nvme0n1p8 vfat (EFI partition that I’ve created, bigger than the first one)

1 Like

I would like to install archlabs on nvme0n1p5, already formatted EXT4
and use nvme0n1p8 as EFI partition, already formatted FAT32

if I have well understood your message, should I mount:

mount /dev/nvme0n1p5 /mnt
mount /dev/nvme0n1p8 /mnt/boot

but probably I’m wrong :slight_smile:

when I do in this way, I’ve got this error message:
The installer expects a full path to a block device for root. e.g. /dev/sda2
Exiting

what am I doing wrong? :slight_smile:

Did you try to follow steps from @natemaia?

#installer -r /dev/nvme0n1p5 -b /dev/nvme0n1p8 /mnt/boot -n

should be:
#installer -r /dev/nvme0n1p5 -b /dev/nvme0n1p8 -n
but I’m now sure :slight_smile:

I got the error:
The installer expects a full path to a block device for root. e.g. /dev/sda2
Exiting

Sorry, lazy copy & paste.

So, to be clear, after you passed in the partitions from cmd line, you got the error?

:+1:
let’s see what @natemaia suggests :slight_smile:

Seem that /dev/nvme0n1p5 is not listed as a block device. In the installation env, post

#ls -asl /dev/nvme0n1p*

2 Likes

Thanks for the info

Let me try to roughly replicate the layout and see wtf is going on.

I’ll look into the flags but it should be correct.

1 Like

Ok I’ve made the exact same layout with my testing laptop which also uses an nvme drive.

p5 is root and p8 is boot, I can recreate the issue where the -r and -b flags don’t work (strange but I’m working on it). I can however pick nvme0n1p8 as the boot partition and install. What partitions are you shown when asked for the boot partition?

I also just want to say I have the same windows install and boot part size of 260M and I don’t have issues with it being too small for a dual boot with linux systems. Obviously not an excuse for you being unable to pick whatever boot partition you want.



2 Likes