Installer bash error

Just downloaded a fresh copy of current AL, verified the sha1sum & attempted to install. Completed all the steps without issue but the install failed almost immediately with a bash error. Followed up with two reboots & two additional installation attempts without success.

I did select bash as the shell.

1 Like

What was the error? Can you get a picture of the screen?

1 Like



I also have the same problem using archlabs-2022.05.29-x86_64.iso in a VirtualBox VM

Sorry forgot link to screenshot

imgur. com/a/dLpNMSy

Sorry to say not getting anywhere with that address but when you install inside of VB leave the video settings as is until the installation is over and you reboot the VB. Then change it to whatever you like.

2 Likes

I just tested a fresh install on my extra pc and can also confirm this is happening when selecting bash… weird because this is the same ISO that worked a few weeks ago to install on my Desktop

1 Like

Encrypted installation?

There have been issues with encrypted installations in the past.. Not sure what will solve your particular case.

Did you try an install with zsh as the shell to see if that went to completion?

1 Like

Welcome to the forum. Can you share that screenshot of the error again please? The link isn’t working, you can embed media now, I have updated the settings.

1 Like

Good spotting. Thanks.

That’s in reply to below…replied post was deleted. :slight_smile:

The link has a space in it.

Corrected link.
https://imgur.com/a/dLpNMSy

1 Like

Yeah, you were too quick for me. :slight_smile:

Do you have an option to edit? You should do, it will save you having to delete your posts. Let me know if you don’t.

Yes, all good here. I didn’t quote the OP in the original post I deleated. So it was easier to start over.

Sweet, you can still post as you would normally when editing (quoting, adding images etc) :smiley:

Sorry I took this off topic people, back on topic now…

1 Like

Yes @PackRat … an encrypted install. I also tried an install with the alternative shell with the same result.

Unfortunately, your link wasn’t available.

Thanks

1 Like

I just did an install on my craptop and encountered the same issue.

I also struck a gpg sgning issue too doing a Gnome + Bash + Vanilla Kernel install.

I just re-created your error twice. Different shells, kernels.

We are diagnosing the issue now. :thinking:

The iso I Iinked wouldn’t help you.

1 Like

If it helps I was playing around with distros yesterday and I also noticed a GPG signing issue with plain ArchLinux.

I will reproduce it today just so we aren’t working off my memories when I was installing like 5-6 distros.

1 Like

GPG validation error when using plain ArchLinux as well with the following command.

pacstrap /mnt base linux linux-firmware

https://imgur.com/a/sM7wUmP