Installation problem

I can link a newer iso with updated installer if anyone is interested to try?

This isn’t my primary focus lately as life has been busy but I’m willing to help individuals looking to install AL over the weekend.

Apologies for the issues. Nate

3 Likes

yes, please share it, I am happy to test

Hi @paolo ,
some 3 week ago, i have tried to install only dwm and it fails with the same screenshot or later with xinit to start the wm.
all is fine if you choose i3 and what you want.
after you change your .xinitrc file, and all is fine.
See if it is not link again with the sourceforge to download package. IT take a long long time.

If I just git cloned the iso repo and followed the build instructions, did I create an up-to-date Archlabs iso, latest changes included? If it is really that easy, is there a need to publish new iso’s? I know, not everyone has a running Arch system to do the build, but this is cool. Thanks.

1 Like

yes , nate please share it,I have the same problem.thx

3 Likes

Yea, there’s likely some small live system changes because I don’t always push my changes to the build until I’m sure they’re staying. Truth be told there is very little reason to do iso builds other than for folks who can do one of

  • use any arch based distro live cd, curl latest installer, run.
  • build an iso locally

AL really is just the installer and a few packages in our repo at this point.

1 Like

Thanks @natemaia,
i will try to install it on a new disk.
I hope the next release will have yaxwm :wink: in choice wm.

1 Like

Possibly, but I wouldn’t get hopes up.

Been floundering on my personal projects the last week, very little changes made. Still no documentation either which is one major thing holding me back (fuckin hate writing docs)

1 Like

yes and for the user it is the RTFM rules :wink: (Read The Fuck…ing Manual)
Here my english is correct, lol
@natemaia Courage

One too many run-ins with one of them eh? Hahaha.

yes :wink:

I have just finished the installation.
if i choose only dwm the installer don’t found something with the make during the dwm build and then the x dwm don’t start. after reboot i have so xauthority not create.
if i choose i3 all is fine.
It is not link with your version of installer, it was the same with the previous, and only for dwm wm if you choose alone.

I’ll do a dwm install and see what’s happening, thanks for testing!

I have just finished the installation.i3 and all is fine.thx

1 Like

Thanks @natemaia I start now the installer

Ok dwm install was failing from the recent minification where most packages aren’t installed anymore unless picked from the menu, so gcc and make weren’t installed; needed for building dwm. Fixed and the installer will update itself so if you just retry the iso I linked and let me know if you have anymore issues.

1 Like

@natemaia I try to install Fluxbox but I have the same error of the official installer, now I restart
the installation

I’m not sure, without a picture or description of the error and command I can’t do much. Just did a fluxbox install and it went fine.

@natemaia I send here the picture I have with the official installer, this evening I have the same error