Installation keeps failing

can someone explain to me what I am doing wrong?
Have now made more than 10 attempts to install archlabs.
Always the message [signature from “Nathaniel Maia natemaia10@gmail.com” is unknown trust], what can I do here to solve this?
I have already interrupted the installer with Ctrl+z to then enter the command sudo pacman-key --refresh-keys and then continue but this was not the solution, can anyone help me?

See …

I used:
sudo pacman-key -r XXXXXXX
sudo pacman-key --lsign-key XXXXXXXX
sudo pacman-key --refresh-keys

but still… nothing

Others are experiencing issues as well. Enjoy your MX, and I’m sure Nate will chime in at some point.

@darknetmatrix
I had same problems
@PackRat led me to posts from @Dobbie03

See this post

@leigh where you can edit your /etc/pacman.conf in the installer?

1 Like

Edit /etc/pacman.conf in the live session before running the installer.

That worked for me yesterday.

2 Likes

I have same problem with Nathaniel Maia natemaia10@gmail.com, when updete archlabs-skel-openbox. PGP signature is invalid or corrupted.

1 Like

Make the same edit to your /etc/pacman.conf

2 Likes

the problem is that i can’t find my way around in the live dk

1 Like

i open a terminal and the command thunar does nothing

1 Like

only saying zsh: command not found: thunar

1 Like

just found it, now the installer runs …

1 Like

For anyone coming to this thread later:

Super + T for terminal


sudo nano /etc/pacman.conf

I was so happy nano was there and not just vim type editor cause that messes with my tiny brain :rofl:

still the same… i ended with a openbox install and nothing from archlabs included :frowning:

as you can see i put Siglevel = Optional TrustAll before [archlabs] but still no

Not a good idea. Don’t do that.

Try to update archlinux and archlabs keyrings first,

$sudo pacman -Sy archlinux-keyring archlabs-keyring

when it asked to import the PGP key from Nathaniel Maia it gives error: required key missing from keyring

Let’s reset all then.

#rm -rf /etc/pacman.d/gnupg
#rm ~/.gnupg
#pacman-key --init
#pacman-key --populate

Have to go to a meeting now. Try to follow archwiki page on package signing to see if you can fix it.

https://wiki.archlinux.org/title/Pacman/Package_signing

1 Like

For me is solved with normal update now :slight_smile: